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A 5.1.0 non-delivery report (NDR) message is returned when users send or forward a message that has embedded HTML content or MIME-based attachments


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Symptoms

Consider the following scenario. You send or forward a message that contains embedded HTML content or MIME-based attachments. However, the recipient receives a non-delivery report (NDR) with text similar to the following:
The following recipient(s) could not be reached:
Test Recipient on 11/9/2005 11:26 PM
The e-mail address could not be found. Perhaps the recipient moved to a different 
e-mail organization, or there was a mistake in the address. Check the address and 
try again.
<EXVirtualServer1.domain.com #5.1.0>

Additionally, other symptoms may occur including messages that have attachments that are queued in the "Local Delivery" queue, or messages that arrive to the recipients with their attachments removed.

NoteThis problem may occur even if there are no virus scanners, and ifthere are no errors in the Application log or System log.

MIME-based content can be anything that is composed by using POP3, IMAP4, or HTTP clients (not richtext/MDBEF).

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Cause

Although there can be several different causes of 5.1.0 NDRs, this solution addresses the scenario where the working directory which is specified in the registry was removed from the NTFS file system.

The most common reasons that the working directory would be removed are as follows:

a) An administrator moved all databases, logs, and checkpoints to a different disk or directory with the belief that the original MDBDATA was no longer used. Therefore, the administrator deleted the original MDBDATA folder manually

or

b) If the Setup.exe program was used to uninstall the Exchange 5.5 administrator program, the Setup program will remove the working directory if it detects that the working directory contains no files. To determine whether the Setup program removed the working directory, search the "Exchange Server Setup Progress.log file" at the root of the system partition for the string that matches the working directory. It will be obvious that the Setup program checks for lack of files in that folder before removing it.

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Resolution

  1. Locate to the following registry key, because the working directory is defined in this registry key:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Working Directory
  2. Note the value of the string, because it should point to a folder on the file system.
    (For installations that use the default path, the value of the working directory is typically set to "C:\Program Files\exchsrvr\mdbdata")
  3. Browse to the path where you would expect the path (noted from step 2) to exist. In the earlier example, it is likely that the MDBDATA folder was removed.Therefore, the Exchange server cannot perform conversion of certain attachments between MIME and richtext format.
  4. Re-create the folder.

You do not have to restart the information store for this change to take effect. After you implement this solution, users may continue to receive the same 5.1.0 NDRs for a while. However, these NDRs will be timestamped before the time of resolution.

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More information

The Exchange best practices analyzer can also detect whether the working directory folder is missing. The working directory is necessary to store temporary files that are used during the content conversion process (known as "IMAIL"). These temporary files are automatically deleted by the information store in a very short timeframe. Therefore, this directory seems to be empty for most of the time.
For more information about symptoms received when the working directory is absent, visit the following Microsoft Web site: http://technet.microsoft.com/en-us/library/28b658a9-2fee-4f1c-a30d-532f7b897a62.aspx

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Keywords: KB924195, kbtshoot, kbprb

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Article Info
Article ID : 924195
Revision : 3
Created on : 11/23/2009
Published on : 11/23/2009
Exists online : False
Views : 270