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When you visit a Web page that uses a custom pop-up object, Internet Explorer 6 closes unexpectedly


View products that this article applies to.

Important update

The problem that this article describes is corrected in the cumulative security update for Internet Explorer. To install the correct update for your environment, install all important or high-priority updates from the Microsoft Update Web site now: Note If you have problems with a security update, no-charge support is available by calling 1-866-PCSAFETY in the United States and in Canada or by contacting your local Microsoft subsidiary. For more information about how to contact your local Microsoft subsidiary for security update support issues, visit the International Support Web site. Enterprise customers can obtain support for security updates through their usual support contacts.

How to troubleshoot similar problems

To troubleshoot similar Internet Explorer stop, restart, or crash problems, self-help steps for a beginning to an intermediate computer user are available in English at the following Microsoft Web site:
Troubleshoot Internet Explorer stop or crash problems

Note This Guided Help content may not be available in all languages.

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Summary

When you visit a Web page that uses a custom pop-up object, Microsoft Internet Explorer 6 closes unexpectedly and generates an error in the Mshtml.dll file. This problem occurs after you install security update 918899 on a Windows XP Service Pack 2 (SP2)-based or a Windows Server 2003 Service Pack 1 (SP1)-based computer. To resolve this problem, we recommend that you install the most current cumulative security update for Internet Explorer.

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Symptoms

You visit a Web page that uses a custom pop-up object. Or, on the home page of a Microsoft Windows SharePoint Services Web site, you click Modify Shared Page, and then click Design this Page. In both scenarios, Microsoft Internet Explorer 6 closes unexpectedly. Additionally, you may receive the following error message:
Internet Explorer has encountered a problem and needs to close. We are sorry for the inconvenience.
If you were in the middle of something, the information you were working on might be lost.
Please tell Microsoft about this problem.
We have created an error report that you can send to help us improve Internet Explorer. We will treat this report as confidential and anonymous.
To see what data this error report contains, click here.
The error report contains the following error-signature information.
ProductAppNameAppVerModNameModVerOffset
Windows XP SP2Iexplore.exe6.00.2900.2180Mshtml.dll6.0.2900.29630006d031
Windows Server 2003 SP1Iexplore.exe6.0.3790.1830Mshtml.dll6.0.3790.2759000b19d6
This problem occurs after you install security update 918899 on a Microsoft Windows XP Service Pack 2 (SP2)-based or a Microsoft Windows Server 2003 Service Pack 1 (SP1)-based computer.

For more information about security update 918899, click the following article number to view the article in the Microsoft Knowledge Base:
918899 MS06-042: Cumulative security update for Internet Explorer
For example, after you install security update 918899, this problem may occur when you visit a Web page that uses the custom menus, the custom message boxes, or the custom tooltips that are documented on the following Microsoft Web site:

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Cause

This problem occurs because of a regression error in security update 918899.

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Resolution

To resolve this problem, install the most current cumulative security update for Internet Explorer, or install update 923996. For more information about the most current cumulative security update for Internet Explorer, visit the following Microsoft Web site: Note This fix was first included in security update 922760. For more information about security update 922760, click the following article number to view the article in the Microsoft Knowledge Base:
922760 MS06-067: Cumulative security update for Internet Explorer

923996 update information

The following files are available for download from the Microsoft Download Center:

Download the Windows XP Service Pack 2 package now.

Download the 32-bit Windows Server 2003 Service Pack 1 package now.

Download the x64-based Windows Server 2003 package now.

Download the Itanium-based Windows Server 2003 Service Pack 1 package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file. This update is scheduled to be included with the next cumulative security update for Internet Explorer, for Windows XP Service Pack 3, and for Windows Server 2003 Service Pack 2.

Prerequisites

The following list contains prerequisites for the update:
  • Internet Explorer 6
  • Security update 918899
  • Windows XP SP2 or Windows Server 2003 SP1

Restart requirement

You must restart the computer after you apply this update.

Deployment information

To install this update without any user interaction, without a display, and without restarting the computer, use the /quiet and /norestart command-line options. For example, to do this on a computer that is running an x86-based version of Windows XP, type the following at a command prompt:
WindowsXP-kb923996-x86-enu.exe /quiet /norestart
For more information about command-line options to install this update, click the following article number to view the article in the Microsoft Knowledge Base:
262841 Command-line switches for Windows software update packages
To verify that this update is installed, confirm that the files that are listed in the "File information" section are installed in the %systemroot%\System32 folder on the computer and that the following registry key exists:
Windows XP SP2
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP\SP3\KB923996
Windows Server 2003 SP1
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows Server 2003\SP2\KB923996

Removal information

To remove this update, follow these steps:
  1. Click Add or Remove Programs in Control Panel.
  2. Remove Windows XP Hotfix - KB923996. If hotfixes are not listed in Add or Remove Programs, click to select the Show Updates check box.
You can also use the Spuninst.exe utility to remove this update. The Spuninst.exe utility is located in the %Windir%\$NTUninstallKB923996$\Spuninst folder. To remove this update without any user interaction, without a display, and without restarting the computer, use the /quiet and /norestart command-line options. For example, to do this on a computer that is running an x86-based version of Windows XP, type the following at a command prompt:
%windir%\$NTUninstallKB923996$\Spuninst\Spuninst.exe /quiet /norestart
For more information about how to use command-line options to remove this update, type the following at a command prompt:
%windir%\$NTUninstallKB923996$\Spuninst\Spuninst.exe /?

Update replacement information

This update does not replace a previously released software update.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP SP2 (32-bit versions)
File nameFile versionFile sizeDateTimeSP requirementService branch
Mshtml.dll6.0.2900.29753,054,08016-Aug-200612:02SP2SP2GDR
Mshtml.dll6.0.2900.29753,058,17616-Aug-200612:09SP2SP2QFE
Windows Server 2003 SP1 (32-bit versions)
File nameFile versionFile sizeDateTimeSP requirementService branch
Mshtml.dll6.0.3790.27713,152,38416-Aug-200614:05SP1SP1GDR
Mshtml.dll6.0.3790.27713,153,92016-Aug-200614:33SP1SP1QFE

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

By default, the error message that is mentioned in the "Symptoms" section is displayed when an unrecoverable error occurs in Internet Explorer. The error message includes an option to send information about the problem to Microsoft. Microsoft analyzes information about these types of errors to try to identify the causes.

The following errors are written to the Application log by Windows Error Reporting:

Windows XP SP2
Date: Date
Time: Time
Type: Error
User: N/A
Computer: Computer name
Source: Application Error
Category: None
Event ID: 1000
Description: Faulting application Iexplore.exe, version 6.00.2900.2180, faulting module Mshtml.dll, version 6.0.2900.2963, fault address 0x0006d031.
Date: Date
Time: Time
Type: Error
User: N/A
Computer: Computer name
Source: Application Error
Category: None
Event ID: 1001
Description: Fault bucket 315386536

Windows Server 2003 SP1
Date: Date
Time: Time
Type: Error
User: N/A
Computer: Computer name
Source: Application Error
Category: None
Event ID: 1000
Description: Faulting application Iexplore.exe, version 6.0.3790.1830, faulting module Mshtml.dll, version 6.0.3790.2759, fault address 0x000b19d6.
Date: Date
Time: Time
Type: Error
User: N/A
Computer: Computer name
Source: Application Error
Category: None
Event ID: 1001
Description: Fault bucket 315429791
Notes
  • IT administrators can use the Corporate Error Reporting (CER) tool to manage error reports and error messages that are created by the Windows Error Reporting (WER) client in Microsoft Windows XP, in Microsoft Windows Server 2003, and in error-reporting (ER) clients that are included in other Microsoft programs. If error-reporting clients are configured to work together with CER 2.0, error reports are redirected to a CER-shared folder instead of being redirected to Microsoft.
  • If you are using CER, you do not see event ID 1001.
  • If Windows Error Reporting is disabled, you may not receive any visual notification when an unrecoverable error occurs. In some cases, you may receive an error message that resembles the following:
    IEXPLORE.EXE - Application Error
    The instruction at "0x7dc9d031" referenced memory at "0x00000020". The memory could not be "read".
    Click on OK to terminate the program.
    Click on CANCEL to debug the program.
    Additionally, an error that resembles the following may be written to the Application log:
    Date: Date
    Time: Time
    Type: Information
    User: N/A
    Computer: Computer name
    Source: Application Popup
    Category: None
    Event ID: 26
    Description: Application popup: IEXPLORE.EXE - Application Error : The instruction at "0x7dc9d031" referenced memory at "0x00000020". The memory could not be "read".
    If you disable error reporting, a Drwtsn32.log file, a User.dmp file, or both files may be created, depending on the system configuration.
For more information about event ID 1000 and about event ID 1001, visit the following Microsoft Web site: For more information about how to disable error reporting, click the following article numbers to view the articles in the Microsoft Knowledge Base:
310414 How to configure and use error reporting in Windows XP
276550 Description and availability of Internet Explorer Error Reporting tool
325075 How to disable error reporting by the Application Error Reporting tool in Office XP
For more information about the Drwtsn32.log file and about the User.dmp file, click the following article number to view the article in the Microsoft Knowledge Base:
308538 Description of the Dr. Watson for Windows (Drwtsn32.exe) tool

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Keywords: atdownload, kbresolve, kbexpertisebeginner, kbwinxpsp3fix, kbwinxppresp3fix, kberrmsg, kbocabucket, kbfix, kbbug, kbqfe, kbwinserv2003sp2fix, KB923996

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Article Info
Article ID : 923996
Revision : 12
Created on : 9/30/2011
Published on : 9/30/2011
Exists online : False
Views : 517