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Public folder content expiry stops working, and event ID 7201 is logged after you move an organization's public folder content to Exchange Server 2003


View products that this article applies to.

Symptoms

After you move an organization's public folder content to Microsoft Exchange Server 2003, the public folder content expiry stops working. When this problem occurs, the following event is logged in the Application log:

Event ID: 7201
Category: General
Source: MSExchangeIS Public Store
Type: Warning
Description: Background thread FDoMaintenance encountered a problem on database "Storage Group\Public Folder Store". Error code 0x8007000e.

Note Error code 0x8007000e corresponds to the following error message:
MAPI_E_NOT_ENOUGH_MEMORY
You experience this problem if the following conditions are true:
  • The organization has many public folders
  • Expiry settings are configured on the individual public folders

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Cause

This problem occurs because of a design limitation in the database maintenance thread. When you have many public folders that have individual expiry settings, the expired objects may not be processed. The database maintenance thread fails, and an ecPropSize error is returned in the JTAB_BASE::EcGetPropByPtagid function for the property that has the ptagReplServerInfo tag. Then, error code 0x8007000e is logged.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, you must have Microsoft Exchange Server 2003 Service Pack 2 (SP2) installed to apply this hotfix. For more information about how to obtain Exchange 2003 Service Pack 2, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the following services automatically stop and restart when you apply this hotfix:
  • Microsoft Exchange Information Store
  • Microsoft Search
  • IIS Admin Service
Additionally, any services that depend on these services are automatically restarted when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Exosal.dll6.5.7651.5070,14425-Sep-200620:53x86
Mdbmsg.dll6.5.7651.503,375,10425-Sep-200620:08x86
Store.exe6.5.7651.505,260,28825-Sep-200620:56x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about the new naming schema for Exchange Server software update packages, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages

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Keywords: kbnosurvey, kbarchive, kbautohotfix, kbeventlog, kbhotfixserver, kbqfe, kbfix, kbbug, kbexchange2003presp1fix, kbexchstore, KB923692

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Article Info
Article ID : 923692
Revision : 4
Created on : 1/15/2015
Published on : 1/15/2015
Exists online : False
Views : 237