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The SenderID filter incorrectly lets an e-mail message pass through Exchange Server 2003 when the DNS record does not exist


View products that this article applies to.

Symptoms

The SenderID filter tries to look up a domain name system (DNS) record that does not exist for an incoming e-mail message in Microsoft Exchange Server 2003. When this occurs, the SenderID filter incorrectly lets the message pass through Exchange Server 2003.

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Cause

This problem occurs because the SenderID filter incorrectly assigns TempError status to the message when the DNS record does not exist.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft Exchange Server 2003 Service Pack 2 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. The Microsoft Internet Information Services (IIS) Admin Service and all dependent services are stopped and then restarted after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Msgfilter.dll6.5.7651.38207,36026-Jul-200616:44x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The SenderID verification process occurs as follows:
  1. A sender sends an e-mail message to the receiver.
  2. The receiver's incoming mail server receives the e-mail message and extracts the Purported Responsible Address (PRA).
  3. The incoming mail server verifies which domain claims to have sent the message. Then, the incoming server examines the DNS for the sender policy framework (SPF) record of that domain.

    Note SPF records identify authorized outgoing e-mail servers.

    The incoming server determines whether the sending e-mail server's IP address matches any of the IP addresses that are published in the SPF record.
  4. If the IP address matches an IP address in the SPF record, the e-mail message is authenticated and delivered to the receiver.

    If the IP address does not match an IP address in the SPF record, the e-mail message fails authentication and is not delivered.
Based on the evaluation of the SenderID record, every message is stamped with a SenderID status. If the DNS record does not exist, the SPF record for the domain should continue to be processed.

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
817903 New naming schema for Exchange Server software update packages

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Keywords: kbnosurvey, kbarchive, kbemail, kbreceivemail, kbHotfixServer, kbqfe, kbfix, kbbug, kbautohotfix, KB923346

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Article Info
Article ID : 923346
Revision : 4
Created on : 1/16/2015
Published on : 1/16/2015
Exists online : False
Views : 225