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The Exchange Information Store service does not start, and an event ID 5000 message is logged in Exchange Server 2003 SP2


View products that this article applies to.

Symptoms

After you upgrade to Microsoft Exchange Server 2003 Service Pack 2 (SP2), the Microsoft Exchange Information Store Service may not start. Additionally, the following event is logged in the Application log:

Event ID: 5000
Source: Exchange IS
Description: Unable to initialize the store service. Failed to search for MSEXCHUCE in DS. 0x80004005

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Cause

This problem may occur if a query for the Intelligent Message Filter (IMF) is made against a domain controller that is under a heavy load. When the Exchange Information Store service in Exchange Server 2003 SP2 starts, it issues a query to check an attribute for the IMF. This query uses lots of resources. When this query is made against a domain controller that is already under heavy load, the domain controller may not respond to the query in a timely manner. Therefore, a time-out may occur during the LDAP query. If a time-out occurs several times, the Exchange Information Store service may not start.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Hotfix installation information

After you apply this hotfix, the query uses an indexed attribute. Therefore, the domain controller does not have to enumerate as many objects to build the response.

Prerequisites

You must install Microsoft Exchange Server 2003 Service Pack 2 (SP2) before you install the hotfix.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply the hotfix. However, the Microsoft Exchange Information Store service and all dependent services will be restarted.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Exosal.dll6.5.7651.4570,14424-Aug-200622:21x86
Exspmsg.dll6.5.7233.418,19208-Aug-200522:02x86
Mdbmsg.dll6.5.7651.453,372,54424-Aug-200616:54x86
Store.exe6.5.7651.455,258,75224-Aug-200622:22x86

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Workaround

To work around this problem, you can temporarily hardcode the Directory Access (DSAccess) component to query domain controllers that are not heavily loaded. You must select domain controllers that can respond to the query before the two-minute time-out period expires. To do this, follow these steps:
  1. Start Exchange System Manager.
  2. Expand Administrative Groups, expand First Administrative Group, and then expand Servers.
  3. Right-click the server that you want, and then click Properties.
  4. Click the Directory Access tab.
  5. In the Show box, click Domain Controllers.
  6. Click to clear the Automatically discover servers check box, and then click Yes when you receive the warning message.
  7. Click Advanced, and then click Find Now.
  8. In the Search results box, click an appropriate entry for a Microsoft Windows Server-based computer, and then click OK three times.
  9. Exit Exchange System Manager.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the terminology that Microsoft uses for software that is corrected after it is released, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about the naming schema for Exchange software updates, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages

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Keywords: KB923171, kbbug, kbfix, kbqfe, kbHotfixServer, kbautohotfix, kbarchive, kbnosurvey

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Article Info
Article ID : 923171
Revision : 4
Created on : 1/16/2015
Published on : 1/16/2015
Exists online : False
Views : 340