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FIX: The program that you try to start in Windows Server 2003 stops responding


View products that this article applies to.

Symptoms

Consider the following scenario. You try to run a program on a Microsoft Windows Server 2003-based computer. You notice the program that you try to run may take a long time to start. Specifically, the program appears to stop responding. Then, the program starts responding after a long unresponsive time.

Additionally, if another program is associated with the program that you try to start, the associated program appears to stop responding also. Usually, Windows Explorer (the Explorer.exe program) is an associated program that appears to stop responding.

For example, you start Windows Explorer to locate a text file. Then, you try to open the text file in Notepad. After you double-click the text file, both Windows Explorer and Notepad appear to stop responding. It may take 15 minutes for the programs to start responding again.

This problem occurs even though the CPU usage is not high and the system disk is almost idle.

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Cause

This problem occurs when the Windows Server 2003-based computer is handling much I/O traffic. For example, this situation may occur when many FTP connections are performing upload and download operations. The upload and download operations may consume I/O resources including Cache Manager. Cache Manager is not disk-based. Therefore, I/O resources may be heavily loaded even though the load on the system disk is small. The high I/O traffic causes the cached disk transfers to increase. These cached disk transfers cause any read requests that are required to start the program to stall. The read requests are delayed until the queue of cached disk transfers are cleared.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer. For more information about how to obtain the latest service pack for Windows Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.27942,459,64816-Sep-200609:35Not ApplicableSP1SP1QFE
Ntkrnlpa.exe5.2.3790.27942,271,23216-Sep-200609:00x86SP1SP1QFE
Ntkrpamp.exe5.2.3790.27942,311,68016-Sep-200609:00Not ApplicableSP1SP1QFE
Ntoskrnl.exe5.2.3790.27942,419,71216-Sep-200609:34x86SP1SP1QFE

Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ntkrnlmp.exe5.2.3790.27946,519,29617-Sep-200604:27IA-64

Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.27944,627,45617-Sep-200604:24x64SP1SP1QFE
Ntoskrnl.exe5.2.3790.27944,482,56017-Sep-200604:24x64SP1SP1QFE

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information about a similar problem that occurs in Windows Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:
898606 Programs that you open appear to stop responding in Windows Server 2003

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Keywords: kbautohotfix, kbwinserv2003presp2fix, kbexpertiseinter, kbbug, kbfix, kbqfe, KB923066

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Article Info
Article ID : 923066
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 262