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DNS dynamic update records are not updated after you manually change the DNS server settings on a computer that is running Windows Server 2003


View products that this article applies to.

Symptoms

After you manually change the Domain Name System (DNS) server settings on a computer that is running Microsoft Windows Server 2003, DNS dynamic update records continue to use the previously configured DNS. This behavior occurs until you either restart the computer or you restart the Dynamic Host Configuration Protocol (DHCP) Client service. In this case, DNS resolution uses the newly configured DNS servers for name queries. If the previously configured DNS servers have been removed from the network, the DNS update records on the client computer are scavenged from DNS because the record timestamps expire. This could lead to a loss of connectivity to the other DNS client computer. Additionally, you may receive the following error message:
System error 53 has occurred.
The network path was not found.

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Cause

This problem occurs because a notification to the DHCP Client Service fails when you change the DNS server setting.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.

Restart information

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Hotfix file information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions with Service Pack 1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhcpcsvc.dll5.2.3790.2746117,24813-Jul-200615:50x86SP1SP1QFE
Windows Server 2003, x64-based versions with Service Pack 1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhcpcsvc.dll5.2.3790.2746225,79213-Jul-200602:48x64SP1Not Applicable
Wdhcpcsvc.dll5.2.3790.2746117,24813-Jul-200602:48x86SP1WOW
Windows Server 2003, Itanium-based versions with Service Pack 1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhcpcsvc.dll5.2.3790.2746308,73613-Jul-200602:47IA-64SP1Not Applicable
Wdhcpcsvc.dll5.2.3790.2746117,24813-Jul-200602:47x86SP1WOW

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Workaround

To work around this problem, restart the DHCP Client service to force the service to use the new settings in the DNS dynamic update records. To do this, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type Net Stop DHCP, and then click OK.
  3. Repeat step 1.
  4. At the command prompt, type Net Start DHCP, and then click OK.
Important notice that you need to restart the DHCP Client service twice if the following conditions are true:
  • You are implementing the Active Directory integrated DNS zones.
  • You have multiple domain controllers.
The first restart of the DHCP Client service might cause the deletion of client�s DNS record from the DNS zone due to the multiple master replication topology. The second restart of DHCP Client service successfully ensures the registration of the one client's record.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

If a Windows DHCP client computer has old DNS addresses that are no longer valid after the DNS server address are changed, the client computer still tries to send DNS dynamic updates to the invalid servers. The Windows DHCP client computer does this even though DNS queries are being made to the newly configured DNS servers.

This problem may occur when you change the DNS server setting by using the Windows Management Instrumentation (WMI) scripting or when you use the TCP/IP setting in Control Panel on a Windows Server 2003 SP1-based computer. You can reproduce this problem in the original release version of Windows Server 2003 if you use the WMI scripting to change the DNS server setting.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbtshoot, kbfix, kbqfe, KB922862

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Article Info
Article ID : 922862
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 221