Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive a blank page when your Web browser submits a POST request to an ASP Web site over an ISA Server 2004 or ISA Server 2006 access rule that requires client authentication


View products that this article applies to.

Symptoms

When your Web browser program submits a POST request to an Active Server Pages (ASP) Web site through Microsoft Internet Security and Acceleration (ISA) Server 2004 or Microsoft Internet Security and Acceleration (ISA) Server 2006, you may receive a blank page in response.

↑ Back to the top


Cause

This problem occurs if the following conditions are true:
  • The following rules are configured in ISA Server 2004 or ISA Server 2006:
    • A Content Type rule that applies to HTTP traffic is configured. This Content Type rule is evaluated when the POST request is processed.
    • An access rule that enables the POST request to be submitted to the Web server is configured. This access rule requires the client to authenticate.
  • The client sends the POST request to ISA Server over an unauthenticated TCP connection.
  • The POST request that the client makes is an HTTP 1.1 request.
  • The Web server sends back an "HTTP 100 Continue" response before it sends the "HTTP 200" response together with the response data.
In this scenario, ISA Server relays the Web server's "HTTP 100 Continue" response to the client as expected. However, ISA Server incorrectly does not send the "HTTP 407 Proxy Authentication Required" request to the client.

↑ Back to the top


Resolution

To resolve this problem, obtain the latest ISA Server Service Pack.
954258 How to obtain the latest Internet Security and Acceleration (ISA) Server 2006 Service Pack
891024 How to obtain the latest ISA Server 2004 Service Pack

↑ Back to the top


Workaround

To work around this problem, configure the client Web browser program to use HTTP 1.0 through proxy connections. To do this in Microsoft Internet Explorer, follow these steps:
  1. Start Internet Explorer.
  2. On the Tools menu, click Internet Options.
  3. In the Internet Options dialog box, click the Advanced tab.
  4. Under HTTP 1.1 settings, click to clear the Use HTTP 1.1 through proxy connections check box, and then click OK.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
885957 How to install ISA Server hotfixes and updates

↑ Back to the top


Keywords: kbarchive, kbfirewall, kbtshoot, kbfix, kbbug, kbprb, kbnosurvey, KB922851

↑ Back to the top

Article Info
Article ID : 922851
Revision : 2
Created on : 1/15/2015
Published on : 1/15/2015
Exists online : False
Views : 399