Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: The Runtimeagent.exe process stops responding when you make concurrent calls by using BizTalk adapter


Symptoms

After you install one or more of the products that are listed in the "Applies to" section, the Runtimeagent.exe process stops responding (hangs) when you make concurrent calls by using one of the products. You may also notice the following symptoms:
  • The BizTalk Adapter does not process messages as expected.
  • Messages do not time out, and no throttling occurs.
  • No related events appear in the event log.
  • The send port instances remain in an active state in BizTalk Administration.
  • If more than one message is submitted to the receive port, only one message is processed at a time.
  • An Oracle adapter trace may not show any communication between the the BizTalk server and the Oracle server.

↑ Back to the top


Cause

This issue occurs because of a timing issue in the Runtimeagent.exe process. This timing issue can cause a deadlock when you make concurrent calls by using one of the products that are listed in the "Applies To" section.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Btcore.dll1.0.1088.02,129,16027-Jul-200623:37
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Workaround

To work around this issue, set the Max Concurrent Calls property to a value of 1 in the BizTalk configuration settings for the adapter.

Note You may experience decreased message processing performance if you set the Max Concurrent Calls property to a value of 1.

↑ Back to the top


References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbpubtypekc, kbfix, kbbtsadapters, kbbts, kb, kbautohotfix, kbbug

↑ Back to the top

Article Info
Article ID : 922810
Revision : 1
Created on : 3/25/2017
Published on : 9/23/2011
Exists online : False
Views : 590