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Handle leaks may occur in the Application Experience Lookup Service on a computer that is running Windows Server 2003 with Service Pack 1


View products that this article applies to.

Symptoms

On a computer that is running Windows Server 2003, handle leaks may occur in the Application Experience Lookup Service (AELookupSvc).

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Cause

This problem may occur in scenarios where multiple processes are created at the same time. These processes require compatibility checks. The Application Experience Lookup Service performs a compatibility check every time that a process is created. This means that every time that a process is created, the Application Experience Lookup Service creates a work item.

In a scenario where the number of work items in the queue is more than the number of worker threads that process the work items in the queue, the Application Experience Lookup Service creates new worker threads. The new worker threads eventually exit but do not close their handles. Therefore, terminated threads are created. This situation causes handle leaks to occur.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

The following list contains prerequisites for the hotfix:
  • Windows Server 2003 SP1
  • Windows Server 2003 SP2
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 with Service Pack 1, x86 version

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File nameFile versionFile sizeDateTimePlatform
Aelupsvc.dll5.2.3790.302126,62408-Oct-200717:23x86
Windows Server 2003 with Service Pack 2, x86 version
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File nameFile versionFile sizeDateTimePlatform
Aelupsvc.dll5.2.3790.416526,62408-Oct-200717:40x86
Windows Server 2003, x64 version
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File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Aelupsvc.dll5.2.3790.302132,76808-Oct-200715:24x64SP1Not Applicable
Waelupsvc.dll5.2.3790.302126,62408-Oct-200715:24x86SP1WOW
Windows Server 2003 with Service Pack 2, x64 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Aelupsvc.dll5.2.3790.416532,76808-Oct-200716:11x64SP2Not Applicable
Waelupsvc.dll5.2.3790.416526,62408-Oct-200716:11x86SP2WOW
Windows Server 2003 with Service Pack 1, IA-64 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Aelupsvc.dll5.2.3790.302156,83208-Oct-200715:24IA-64SP1Not Applicable
Waelupsvc.dll5.2.3790.302126,62408-Oct-200715:24x86SP1WOW
Windows Server 2003 with Service Pack 2, IA-64 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Aelupsvc.dll5.2.3790.416556,83208-Oct-200716:02IA-64SP2Not Applicable
Waelupsvc.dll5.2.3790.416526,62408-Oct-200716:02x86SP2WOW

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More information

The Application Experience Lookup Service is a service that runs in the Svchost.exe process. When a process or program starts, the Application Experience Lookup Service determines whether the program or process requires compatibility updates. If no compatibility updates are required for the executable file, the executable file is cached.

Caching the executable file prevents the Application Experience Lookup Service from performing an unnecessary compatibility check the next time that the program or process starts. However, some executable files, such as Cmd.exe, are never cached. For more information about the Application Experience Lookup Service, click the following article number to view the article in the Microsoft Knowledge Base:
902196� Description of the Application Experience Lookup Service in Windows Server 2003 Service Pack 1

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbhotfixserver, kbqfe, kbautohotfix, kbbug, kbexpertiseinter, KB922757

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Article Info
Article ID : 922757
Revision : 2
Created on : 7/17/2008
Published on : 7/17/2008
Exists online : False
Views : 418