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Outlook 2003 crashes after you move your mailbox to a server that is running Exchange Server 2003 SP2


View products that this article applies to.

Symptoms

After you move your mailbox to a server that is running Microsoft Exchange Server 2003 Service Pack 2 (SP2), Microsoft Office Outlook 2003 crashes when you change an Outlook 2003 folder. For example, Outlook 2003 crashes when you add an item to a folder. Additionally, the following event is logged in the Application log:

Event Type: Error
Event Source: Microsoft Office 11
Event Category: None
Event ID: 1000
Description: Faulting application outlook.exe, version 11.0.8000.0, stamp 43599e06, faulting module ntdll.dll, version 5.1.2600.2180, stamp 411096b4, debug? 0, fault address 0x0000eddc.

Additionally you receive one of the following error messages.
  • If Outlook 2003 is running in cached mode, you receive the following error message when you try to open Outlook:
    Cannot start Microsoft Outlook. Unable to open the Outlook Window. The set of folders could not be opened.
  • If Outlook 2003 is running in online mode, you receive the following error message when you try to open Outlook:
    Microsoft Outlook has encountered a problem and needs to close. We are sorry for the inconvenience.
Note If you move the mailbox back to the original store, this behavior no longer occurs.

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Cause

This problem occurs because of a difference between the ReplidMap table in the memory on the server and the ReplidMap table in the Jet database. This difference causes a stack overflow that causes Outlook 2003 to crash. When Outlook 2003 constructs an entry identifier for an item, Outlook 2003 combines a GUID together with the item counter for the item. The GUID is determined by using an index for the item. In this case, Outlook 2003 uses different methods to request the entry identifier. These different methods return different entry identifiers. One entry identifier contains data that was returned from the Jet database. The other entry identifier contains data that was returned from the memory cache.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange Server 2003 Service Pack 2 (SP2).

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

When you install this hotfix, the following services will be restarted:
  • The Microsoft Exchange Information Store service
  • The Microsoft Search service
  • The IIS Admin service and all dependent services

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Exosal.dll6.5.7651.5370,14403-Oct-200617:35x86
Mdbmsg.dll6.5.7651.533,375,10403-Oct-200616:50x86
Mdbrest.dll6.5.7651.53560,64003-Oct-200601:35x86
Store.exe6.5.7651.535,257,21603-Oct-200617:38x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

By default, the memory cache that includes the cached GUID information and the cached ReplidMap table information is enabled in Exchange Server 2003 SP2. This cache is disabled in Microsoft Exchange Server 2003 Service Pack 1 (SP1). This hotfix disables this cache.

You can configure the registry to manually disable this cache. However, we recommended that you apply this hotfix. To manually disable this cache, create a new registry entry that is named Guid-Replid Caching under every mailbox store registry subkey. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\<Mailbox Store GUID>
    Note In this registry subkey, <ServerName> is the name of the Exchange server. And, <Mailbox Store GUID> is the GUID of the mailbox store.
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type Guid-Replid Caching to name this new entry, and then press ENTER.
  5. Right-click Guid-Replid Caching, and then click Modify.
  6. Under Base, click Decimal.
  7. In the Value data box, type 0, and then click OK.
  8. After you configure this registry entry for all the mailbox stores, you must restart the computer.
Note You have to create the Guid-Replid Caching registry entry for all mailbox stores to disable this cache. Additionally, the Guid-Replid Caching registry entry can also be implemented on a server that is running Microsoft Exchange Server 2007 when you experience the problem that is mentioned in the "Symptoms" section.

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Keywords: KB922617, kbbug, kbfix, kbqfe, kbHotfixServer, kbautohotfix, kbarchive, kbnosurvey

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Article Info
Article ID : 922617
Revision : 5
Created on : 1/16/2015
Published on : 1/16/2015
Exists online : False
Views : 407