Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

When you change any file attribute in Windows Explorer, the archive attribute is cleared if the volume cluster size is larger than 4 KB in Windows Server 2003 and in Windows XP


View products that this article applies to.

Symptoms

When you change any file attribute in Windows Explorer, the archive attribute is cleared if the volume cluster size is larger than 4 kilobytes (KB) in Microsoft Windows Server 2003 and in Windows XP.

Specifically, this problem occurs when you format a disk volume into an NTFS volume by using a cluster size that is larger than 4 KB. You change one or more attributes for a file that resides on this volume in Windows Explorer. If you modify any of the following attributes, the archive attribute is cleared, and you cannot enable the archive attribute again:
  • For fast searching, allow Indexing Services to index this file
  • File is ready for archiving
  • Encrypt contents to secure data

↑ Back to the top


Cause

This problem occurs because Windows Server 2003 and Windows XP do not support compression for volumes that have cluster sizes that are larger than 4 KB. In this scenario, Windows Explorer does not verify the archive attribute.

↑ Back to the top


Resolution

Windows Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

Prerequisites
This hotfix has no prerequisites.
Restart requirement
You must restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Shell32.dll6.0.3790.5878,174,08031-Aug-200615:07x86
Windows Server 2003 Service Pack 1 (SP1), x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Shell32.dll6.0.3790.27818,384,51231-Aug-200615:22x86SP1
W03a2409.dll5.2.3790.278127,13631-Aug-200613:29x86SP1
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Shell32.dll6.0.3790.58712,973,05631-Aug-200600:37IA-64Not Applicable
Wshell32.dll6.0.3790.5878,174,08031-Aug-200600:37x86WOW
Windows Server 2003 SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shell32.dll6.0.3790.278113,240,83231-Aug-200600:42IA-64SP1Not Applicable
W03a2409.dll5.2.3790.278126,11231-Aug-200600:42IA-64SP1Not Applicable
Wshell32.dll6.0.3790.27818,384,51231-Aug-200600:42x86SP1WOW
Ww03a2409.dll5.2.3790.278127,13631-Aug-200600:42x86SP1WOW
Windows Server 2003 SP1, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shell32.dll6.0.3790.278110,503,16831-Aug-200600:42x64SP1Not Applicable
W03a2409.dll5.2.3790.278127,64831-Aug-200600:42x64SP1Not Applicable
Wshell32.dll6.0.3790.27818,384,51231-Aug-200600:42x86SP1WOW
Ww03a2409.dll5.2.3790.278127,13631-Aug-200600:42x86SP1WOW

Windows XP

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must have Windows XP Service Pack 2 installed on the computer to apply this hotfix.
Restart requirement
You must restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows XP Service Pack 2 (SP2), x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Shell32.dll6.0.2900.29958,458,24013-Sep-200611:02x86SP2
Xpsp3res.dll5.1.2600.2995210,94413-Sep-200608:56x86SP2
Windows XP, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shell32.dll6.0.3790.278110,503,16831-Aug-200600:42x64SP1Not Applicable
W03a2409.dll5.2.3790.278127,64831-Aug-200600:42x64SP1Not Applicable
Wshell32.dll6.0.3790.27818,384,51231-Aug-200600:42x86SP1WOW
Ww03a2409.dll5.2.3790.278127,13631-Aug-200600:42x86SP1WOW

↑ Back to the top


Workaround

To work around this problem, enable the archive attribute by using the attrib command. To do this, run the following command at the command prompt:
attrib <FileName> +a
Note Replace the <FileName> placeholder in the command with the file for which you want to enable the archive attribute.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbwinserv2003sp2fix, kbbug, kbfix, kbHotfixServer, kbqfe, KB922599

↑ Back to the top

Article Info
Article ID : 922599
Revision : 4
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 292