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You cannot recover some public folders in Exchange Server 2003 Outlook Web Access, and the information store becomes unavailable to users


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Symptoms

When you use Microsoft Exchange Server 2003 Outlook Web Access to recover public folders, you cannot recover some large, nested public folders. Additionally, the information store becomes unavailable to users.

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Cause

This issue occurs if the version store reaches its size limit during the recovery process.

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Workaround

To work around this issue, you can temporarily increase the size limit of the version store. The setting for the msExchESEParamMaxVerPages attribute for the storage group object in the Active Directory directory service determines the size limit of the version store. This setting is in units of 16 kilobytes (KB). By default, the msExchESEParamMaxVerPages attribute is set to 9,280 KB. To resolve this issue, you can increase the attribute to 20,000 KB. However, this setting leaves less available memory for other functions in the version store. Additionally, this setting may cause other performance issues.

To increase the size limit of the version store, follow these steps.

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.
  1. Install the Microsoft Windows Server 2003 Support Tools. To do this, follow these steps:
    1. Insert the Windows Server 2003 CD into the computer's CD drive.
    2. Click Start, click Run, and then click Browse.
    3. Locate the following folder on the CD:
      CD_drive:\Support\Tools
    4. In the Files of type list, click All Files.
    5. Click Suptools.msi, click Open, and then click OK.
    6. Follow the directions in the Windows Support Tools Setup Wizard.
  2. Start ADSIEdit.

    If you have not configured ADSIEdit, follow these steps:
    1. Click Start, click Run, type mmc in the Open box, and then click OK.
    2. On the File menu, click Add/Remove Snap-in.
    3. Click the Standalone tab, and then click Add.
    4. In the Snap-in list, click ADSIEdit, click Add, and then click Close.
  3. Right-click ADSIEdit, and then click Connect to.
  4. In the Connection Point area, click Select a well known Naming Context, and then click Configuration in the Select a well known Naming Context list.
  5. In the Computer area, click Default (Domain or server that you logged in to), and then click OK.
  6. In the left pane, expand ADSIEdit, expand Configuration, expand CN=Configuration, expand CN=Services, expand CN=Microsoft Exchange, and then expand CN=Your_Organization_Name. Then, expand CN=Administrative Groups, expand Your_Administrative_Group, expand CN=Servers, expand Server_Name, and then expand CN=Information Store.
  7. Right-click the storage group of which the affected computer that is running Exchange Server 2003 is a member, and then click Properties.
  8. In the Attribute list, double-click msExchESEParamMaxVerPages, type 20000 in the Value box, and then click OK two times.
  9. Minimize ADSIEdit.
  10. Try to recover the public folders.
  11. Reset the msExchESEParamMaxVerPages value to 9,280 KB.

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More information

To check which domain controller is the current Configuration domain controller, follow these steps:
  1. Click Start, point to All Programs, point to Microsoft Exchange, and then click System Manager.
  2. Expand the Exchange organization, expand Servers, right-click Server_Name, and then click Properties.

    On the Directory Access tab, the domain controller that is selected as the Config (auto) type is the current Configuration domain controller.

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Keywords: KB922501, kbprb, kbtshoot, kbexchangeowa, kbexchdirectory

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Article Info
Article ID : 922501
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 280