Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A Windows Hardware Compatibility Test for an array fails when you are running Windows Server 2003 R2 Virtual Disk Service 1.1


View products that this article applies to.

Symptoms

Microsoft Windows Server 2003 R2 Virtual Disk Service (VDS) 1.1 may not work correctly if the following conditions are true:
  • You use an active array in a Storage Area Network (SAN).
  • The SAN uses both page 83 and page 80 to present the Vital Product Data (VPD) pages. (These pages represent the SAN "unique serial number" for the array enclosure.)
In this scenario, a Windows Hardware Compatibility Test for the array fails.

↑ Back to the top


Cause

This issue may occur if the array controller uses more than one data page, or unique serial number, to identify an array.

The VDS 1.1 architecture supports only one unique serial number (page code 0x80h) in ASCII for array logical unit numbers (LUNs). VDS 1.1 compares this serial number with the Windows system level core I/O that is buffered in page 80. VPD pages 0x80 and 0x83 represent unique identification data for the array LUNs. If a SAN implementation also uses page code 80h on each controller, multiple serial numbers are presented to VDS. This behavior causes VDS to fail.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

When you install this hotfix, the page checks are not performed. Therefore, unique serial numbers are used.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running Windows Server 2003 R2.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 R2, x86-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Vds.exe5.2.3790.2738352,25602-Jul-200613:21x86SP1QFE
Vdsbas.dll5.2.3790.2738141,82402-Jul-200615:54x86SP1QFE
Vdsdyndr.dll5.2.3790.2738326,14402-Jul-200615:54x86SP1QFE
Vdsldr.exe5.2.3790.273819,45602-Jul-200613:21x86SP1QFE
Vdsutil.dll5.2.3790.273861,95202-Jul-200615:54x86SP1QFE
Vds_ps.dll5.2.3790.273830,72002-Jul-200615:54x86SP1QFE
Windows Server 2003 R2, x64-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Vds.exe5.2.3790.2738612,86402-Jul-200616:30x64SP1QFE
Vdsbas.dll5.2.3790.2738254,97602-Jul-200616:30x64SP1QFE
Vdsdyndr.dll5.2.3790.2738456,19202-Jul-200616:30x64SP1QFE
Vdsldr.exe5.2.3790.273829,69602-Jul-200616:30x64SP1QFE
Vdsutil.dll5.2.3790.273894,72002-Jul-200616:30x64SP1QFE
Vds_ps.dll5.2.3790.273841,47202-Jul-200616:30x64SP1QFE
Wvds_ps.dll5.2.3790.273830,72002-Jul-200616:30x86WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

↑ Back to the top


Keywords: kbautohotfix, kbwinserv2003presp2fix, kbhotfixserver, kbqfe, kbexpertiseinter, KB922387

↑ Back to the top

Article Info
Article ID : 922387
Revision : 9
Created on : 3/28/2007
Published on : 3/28/2007
Exists online : False
Views : 543