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FIX: Error message when you try to run an ASP.NET 2.0 Web application that includes Web services: "The file <FilePath> does not exist"


View products that this article applies to.

Symptoms

When you try to run a Microsoft ASP.NET 2.0 Web application that includes Web services, you continuously receive the following error message:
The file <FilePath> does not exist
Note In this error message, <FilePath> is placeholder for the path of the .aspx file.

You continuously receive this error message until the Microsoft Internet Information Services (IIS) application pool that hosts the ASP.NET 2.0 Web application is recycled.

This problem may occur when you run the ASP.NET 2.0 Web application in a high-load environment.

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Cause

This problem occurs because the code that generates the Web Services Description Language (WSDL) file may unregister any VirtualPathProviders class that is used by the ASP.NET 2.0 Web application. This problem may occur if more than one WSDL help request is in process. If the VirtualPathProviders classes are unregistered, any content that resides on the virtual path may be inaccessible.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have ASP.NET 2.0 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces the hotfixes that are described in the following Microsoft Knowledge Base articles:
911276� FIX: Error message when you try to go to an ASP.NET page by using a URL that contains Unicode characters: "HTTP error 400 'bad request'"
913393� FIX: You receive an exception error message when you specify a Content-Length HTTP header that is larger than 2 GB in ASP.NET 2.0
915782� FIX: You may receive an InvalidCastException error in an ASP.NET-connected Web application
918181� FIX: You receive a ThreadAbortException exception in an ASP.NET Web application that is based in the .NET Framework 2.0 when the Async page directive property is set to true
920970� FIX: You may experience an unexpected AppDomain restart in an ASP.NET Web application that is based on the .NET Framework 2.0

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
The Microsoft .NET Framework 2.0, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Aspnet_wp.exe2.0.50727.17423,04001-Jul-200606:53
Webengine.dll2.0.50727.174300,03201-Jul-200606:53
System.Web.dll2.0.50727.1745,025,79201-Jul-200606:53
The Microsoft .NET Framework 2.0, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Aspnet_wp.exe2.0.50727.17434,81630-Jun-200622:12
Aspnet_wp.exe2.0.50727.17423,04001-Jul-200606:53
Webengine.dll2.0.50727.174540,67230-Jun-200622:12
Webengine.dll2.0.50727.174300,03201-Jul-200606:53
System.Web.dll2.0.50727.1744,960,25601-Jul-200603:12
System.Web.dll2.0.50727.1745,025,79201-Jul-200606:53
The Microsoft .NET Framework 2.0, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Aspnet_wp.exe2.0.50727.17473,72830-Jun-200622:18
Aspnet_wp.exe2.0.50727.17423,04001-Jul-200606:53
Webengine.dll2.0.50727.174868,86430-Jun-200622:18
Webengine.dll2.0.50727.174300,03201-Jul-200606:53
System.Web.dll2.0.50727.1744,595,71201-Jul-200604:00
System.Web.dll2.0.50727.1745,025,79201-Jul-200606:53

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Workaround

To work around this problem, recycle the IIS application pool that hosts the ASP.NET 2.0 Web application to register the VirtualPathProviders classes again. To do this, follow these steps:
  1. Click Start, click Run, type inetmgr, and then click OK.
  2. Expand <Server Name>, and then expand Application Pools.

    Note <Server Name> is a placeholder for the name of the computer on which you want to recycle the IIS application pool.
  3. Right-click the IIS application pool that you want to recycle, and then click Recycle.
  4. Right-click <Server Name>.
  5. Click All Tasks, and then click Restart IIS.
  6. Click OK.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

This hotfix becomes effective the next time that the IIS application pool is recycled.

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB922345, kbpubtypekc, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbautohotfix

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Article Info
Article ID : 922345
Revision : 4
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 342