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Installation fails and you may be prompted for the Exchange Server 5.5 Service Account password when you upgrade to Exchange Server 2003


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Symptoms

You upgrade from Microsoft Exchange 2000 Server or from Microsoft Exchange Server 5.5 to Microsoft Exchange Server 2003. When you do this, the installation fails. Additionally, you may be prompted for the Exchange Server 5.5 Service Account password. The Exchange Server Setup Progress.log file contains information that resembles the following information:
*****************
[16:58:34] There are no 5.5 servers on the site. About to check if the site is in mixed mode.
[16:58:34] Entering ScGetAdminGroupModeForSite
[16:58:34] AdminGroup Mode = 2.
[16:58:34] Leaving ScGetAdminGroupModeForSite
[16:58:34] dminGroup is in a mixed mode. There are no 5.5 servers but an SRS exists. We WILL need the password
[16:58:34] Leaving ScDetermineIfMixedAdminGroupOrSRSRequires55ServiceAccount
[16:58:34] We have detected that the 5.5 account info IS required
[16:59:29] CAccount::Set - Account is being reset to = (�\)
[16:59:29] CAccount::Not setting the password on the 5.5 Service Account (no username was passed)
[16:59:36] CAccount::Set - Account is being reset to = (�\)
[16:59:36] CAccount::Not setting the password on the 5.5 Service Account (no username was passed)
[16:59:51] CAccount::Set - Account is being reset to = (�\)
[16:59:51] CAccount::Not setting the password on the 5.5 Service Account (no username was passed)
[17:00:17] CComBOIFacesFactory::QueryInterface (f:\titanium\admin\src\udog\bo\bofactory.cxx:54) Error code 0X80004002 (16386): No interface.
***************
Additionally, the operation mode in Exchange System Manager is set to native mode. When you review the Exchange Server Setup Progress.log, you see that the AdminGroup Mode value equals 2. This indicates that the Exchange Server 2003 organization is in mixed mode.

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Cause

This issue occurs because an older Exchange Administrator account still exists. Additionally, the operation mode is not successfully changed to native mode.

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Resolution

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.

To resolve this issue, follow these steps:
  1. Install the Microsoft Windows Server 2003 Support Tools. To do this, follow these steps:
    1. Insert the Windows Server 2003 CD into your computer's CD drive.
    2. Click Start, click Run, and then click Browse.
    3. Locate the following folder on the CD:
      CD_drive:\Support\Tools
    4. In the Files of type list, click All Files.
    5. Click Suptools.msi, click Open, and then click OK.
    6. Follow the directions in the Windows Support Tools Setup Wizard.
  2. Start ADSIEdit.

    If you have not configured ADSIEdit, follow these steps:
    1. Click Start, click Run, type mmc in the Open box, and then click OK.
    2. On the File menu, click Add/Remove Snap-in.
    3. Click the Standalone tab, and then click Add.
    4. In the Snap-in list, click ADSIEdit, click Add, and then click Close.
  3. Right-click ADSIEdit, and then click Connect to.
  4. In the Connection Point area, click Select a well known Naming Context, and then click Configuration in the Select a well known Naming Context list.
  5. In the Computer area, click Default (Domain or server that you logged in to), and then click OK.
  6. In the left pane, expand ADSIEdit, expand Configuration, expand CN=Configuration, expand CN=Services, expand CN=Microsoft Exchange, expand CN=Your_Organization_Name, and then click CN=Administrative Groups.
  7. Right-click the administrative group of which the affected computer that is running Exchange 2000 Server or Exchange Server 5.5 is a member, and then click Properties.
  8. In the Attribute list, double-click msExchEncryptedPassword, click Clear, and then click OK.
  9. In the Attribute list, double-click msExchLegacyAccount, click Clear, and then click OK.
  10. In the Attribute list, double-click msExchLegacyDomain, click Clear, and then click OK.
  11. In the Attribute list, double-click msExchAdminGroupMode, type 0 in the Value box, and then click OK two times.

    Note A value of 2 indicates that the administrative group is in mixed mode. A value of 0 indicates that the administrative group is pure Exchange 2000 Server.
  12. Close ADSIEdit.

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Keywords: KB922259, kberrmsg, kbprb, kbtshoot, kbsetup

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Article Info
Article ID : 922259
Revision : 3
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 214