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Error message when you try to run a report or upload a report in Microsoft Dynamics CRM: "The request failed with HTTP status 401: Unauthorized" or "Server Error in ‘/’ Application"


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Symptoms

Symptom 1

When you try to run a report in Microsoft Dynamics CRM 3.0, you receive the following error message:

The request failed with HTTP status 401: Unauthorized.

When you try to run a report in Microsoft Dynamics CRM 4.0, you receive the following error message:

Error
An error has occurred. Try this action again. If the problem continues, check the Microsoft Dynamics CRM Community for solutions or contact your organization’s Microsoft Dynamics CRM Administrator. Finally, you can contact Microsoft Support.



When you try to run a report in Microsoft Dynamics CRM 2011, you receive the following error message:

Reporting Error
The Report cannot be displayed. (rsAccessDenied)

With DevErrors enable, you receive an error similar to the following messages:

Error Description:

The permissions granted to user 'NT AUTHORITY\NETWORK SERVICE' are insufficient for performing this operation.



Error Details:

The permissions granted to user 'NT AUTHORITY\NETWORK SERVICE' are insufficient for performing this operation.

Symptom 2

When you try to add a report in Microsoft Dynamics CRM 3.0, you receive the following error message:

Error Uploading Report
An error occurred while trying to add the report to Microsoft CRM. Try adding the report again. If the problem continues, contact your system administrator.

With DevErrors enabled, you receive the following error:
Server Error in ‘/’ Application.
Exception of type Microsoft.Crm.CrmException was thrown.

When you try to add a report in Microsoft Dynamics CRM 4.0 or in Microsoft Dynamics CRM 2011, you receive the following error message:

An error occurred while trying to add the report to Microsoft Dynamics CRM. Try this action again. If the problem continues, check the Microsoft Dynamics CRM Community for solutions or contact your organization's Microsoft Dynamics CRM Administrator. Finally, you can contact Microsoft Support.


Error code: 0x80048298


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Cause

This problem occurs because the security account for the CRMAppPool application pool does not have the Publisher for Microsoft Dynamics CRM role in Report Manager.

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Resolution

To resolve this problem, follow these steps:

  1. Find the user. To do this, follow these steps:
    1. On the Microsoft Dynamics CRM server, click Start, click Run, type compmgmt.msc /s, and then click OK to open Computer Management.
    2. Expand Services and Applications, expand Internet Information Services (IIS) Manager, expand Application Pools, right-click CRMAppPool, and then click Properties.
    3. In the CRMAppPool Properties dialog box, note the value in the Predefined box on the Identity tab.

  2. Grant the Publisher for Microsoft Dynamics CRM role to the user identified in the previous steps. To do this, follow these steps:
    1. Type the following address in the Address bar in Microsoft Internet Explorer, and then click Go to open Reporting Services Report Manager:
      http://SRSServer/Reports
      Note SRSServer is a placeholder that represents an actual name of a Microsoft SQL Server Reporting Services server.

      Note If you cannot log in to Reporting Services, see http://technet.microsoft.com/en-us/library/bb630430.aspx.
    2. Click the Microsoft Dynamics CRM company name folder.

      Note The Microsoft Dynamics CRM company name resembles the following:
      CRM_Company_Name_MSCRM
    3. On the Properties tab, click Security.

      Note For SQL Reporting Services 2008, hover your mouse over the folder, click the drop-down arrow, and then select Security
    4. Check to see whether the user who you found in step 1 is listed with the Publisher for Microsoft CRM role.

      Note If Microsoft Dynamics CRM and SQL Reporting Services are on the same server, and the CRMAppPool identity is running as NETWORK SERVICE, the NT AUTHORITY\NETWORK SERVICE account should have the Publisher for Microsoft CRM role. If Microsoft Dynamics CRM and SQL Reporting Services are on separate servers, and the CRMAppPool identity is running as NETWORK SERVICE, the <domain>\<crmserver>$ account should have the Publisher for Microsoft CRM role. The <domain>\<crmserver>$ account can either be granted the Publisher for Microsoft CRM role directly or by being a member of the SQLAccessGroup in Active Directory and by granting the SQLAccessGroup the Publisher for Microsoft CRM role.

      Note If the user is not listed, click New Role Assignment.
      In the Group or user name box, type the name of the user who you noted in step 1c.
    5. Click to select the Publisher for Microsoft CRM check box, and then click OK.
    6. In Microsoft Dynamics CRM 2011, the Out of Box Reports are stored in the SharedReports folder. Therefore, you must also make sure that the permissions are added to this folder if users cannot view Out of Box Reports. When reports are uploaded to Dynamics CRM 2011, they are published to the Organization_MSCRM folder for that organization.

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Keywords: kbmbscrm40, kbfreshness2007, kbtshoot, kbmbsreports, kbmbspartner, kberrmsg, kbmbsmigrate, kbprb, kb

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Article Info
Article ID : 921546
Revision : 4
Created on : 3/30/2017
Published on : 3/30/2017
Exists online : False
Views : 1078