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Error message when you try to create a database connection to SQL Server Express in a Windows Server 2003-based terminal server session: "Failed to spawn a user instance of SQL Server"


View products that this article applies to.

Symptoms

Consider the following scenario. You establish a terminal server session with a computer that is running a 64-bit version of Microsoft Windows Server 2003. In the terminal server session, you use Microsoft Visual Studio to create a database connection to Microsoft SQL Server Express. When you create this database connection, you specify the following query for the connection string:
User Instance=True
In this scenario, you receive the following error message:
Failed to spawn a user instance of SQL Server due to a failure in starting the process for the user instance. The connection will be closed.

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Cause

When an application creates a connection to SQL Server Express in a terminal server session, SQL Server Express tries to create a cross-session process. The packet that is sent from a 32-bit process has the 32-bit data type. However, the current execution service on a 64-bit operating system can recognize only the 64-bit data type. Therefore, SQL Server Express cannot create a cross-session process.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Wlnotify.dll5.2.3790.2730247,29621-Jun-200609:04IA-64
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Wlnotify.dll5.2.3790.2730152,06421-Jun-200609:04x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kberrmsg, kbwinserv2003presp2fix, kbexpertiseinter, kbbug, kbfix, kbqfe, kbwinserv2003sp2fix, KB921498

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Article Info
Article ID : 921498
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 211