Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Microsoft CRM Mobile Device Registration Service and the Microsoft CRM Mobile Integration Service do not start after you install Microsoft CRM Mobile


View products that this article applies to.

Symptoms

After you install Microsoft Dynamics CRM Mobile, the Microsoft CRM Mobile Device Registration Service and the Microsoft CRM Mobile Integration Service do not start. Or, these components start but then stop responding.

Additionally, the following event is logged in the Application log on the Microsoft Dynamics CRM server:
Event Type:	Error
Event Source:	MBSIntegrationService
Event Category:	(40)
Event ID:	4000
Date:		3/3/2006
Time:		10:03:56 AM
User:		N/A
Computer:	CRMSERVER
Description:
Exiting service abruptly. Details: Exception details : 
	Source : System.Web.Services
	Message : The request failed with HTTP status 502: Proxy Error ( The host was not found. ).
	Extra Info : Status Code : BadGatewayStatus Description : Proxy Error ( The host was not found. )
	Exception Contents : System.Net.WebException: The request failed with HTTP status 502: Proxy Error ( The host was not found. ).
   at Microsoft.BusinessSolutions.Mobility.Exceptions.MbsMoException.Throw(Exception exception)
   at Microsoft.BusinessSolutions.Mobility.Integration.JobProcessor.ExecuteJobs(Object o)

For more information, see Help and Support Center at http://support.microsoft.com.

↑ Back to the top


Cause

This problem occurs because the Domain Name System (DNS) is not set up to enable Fully Qualified Domain Name (FQDN) resolution.

↑ Back to the top


Resolution

To resolve this problem, edit the following files by using the NetBIOS name of the Microsoft Dynamics CRM server:
MBSDeviceRegistrationService.exe.config
MBSIntegrationService.exe.config
CRMMobile.exe.config
Notes
By default, the MBSDeviceRegistrationService.exe.config file and the MBSIntegrationService.exe.config file are stored in the following location:
C:\Program Files\Microsoft CRM\CRM Mobile\bin
By default, the CRMMobile.exe.config file is stored in the following location:
C:\Program Files\Microsoft CRM\CRM Mobile\Configuration
To edit these files, follow these steps:
1.Open the MBSDeviceRegistrationService.exe.config file in Notepad.
2. Search for Machinename.Domain.com.

Note Machinename is a placeholder for the NetBIOS name of the Microsoft Dynamics CRM server. Domain is a placeholder for the actual name of the domain.
3.Replace Machinename.Domain.com with Machinename.
4. Save the file.
5. Restart the affected service.
6.Repeat steps 2 through 5 for the MBSIntegrationService.exe.config file and for the CRMMobile.exe.config file.

↑ Back to the top


Keywords: KB921388, kbprb, kbmbsmigrate, kbtshoot, kberrmsg

↑ Back to the top

Article Info
Article ID : 921388
Revision : 2
Created on : 9/22/2006
Published on : 9/22/2006
Exists online : False
Views : 294