Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot open Access report snapshot (.snp) files in Internet Explorer after you install Windows XP Service Pack 2


View products that this article applies to.

Symptoms

When you try to open a Microsoft Office Access 2003 report snapshot (.snp) file in Microsoft Internet Explorer, you are prompted to save the .snp file instead of opening it directly in Internet Explorer.

Note This problem occurs after you install Microsoft Windows XP Service Pack 2 (SP2) on a computer where Access 2003 is already installed.

↑ Back to the top


Cause

This problem occurs because .snp files are associated with Access 2003 after you install Windows XP SP2. Originally, .snp files were associated with the Snapshot Viewer application.

↑ Back to the top


Workaround

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To work around this problem, follow these steps.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_CLASSES_ROOT\.snp
  3. Double-click the Content Type registry entry, and then replace the existing value with application/snapview.

↑ Back to the top


Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB921025, kbtshoot, kbbug, kbexpertisebeginner

↑ Back to the top

Article Info
Article ID : 921025
Revision : 3
Created on : 6/27/2006
Published on : 6/27/2006
Exists online : False
Views : 224