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When a Linux-based client computer tries to access a domain controller that is running Windows Server 2003 or Windows 2000, an access violation occurs


View products that this article applies to.

Symptoms

You are using a Linux-based client computer in an Active Directory directory service domain where the domain controller is running Microsoft Windows Server 2003 or Microsoft Windows 2000. When the client computer tries to access the domain controller, heap corruption may occur on the domain controller. The heap corruption deletes data from valid memory addresses and generates an access violation in the LSASS service.

Note This access violation causes the domain controller to crash.

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Cause

This behavior occurs when the following conditions are true:
  • A Linux client computer tries to query the domain controller by using a signed and sealed Lightweight Directory Access Protocol (LDAP) request.
  • The LDAP bind calls use encryption buffers that are smaller than the encryption block size.

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Resolution

Windows Server 2003 service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:
  • An Itanium-based version of Windows Server 2003 with Service Pack 1 (SP1)
  • A 32-bit version of Windows Server 2003 with Service Pack 1 (SP1)
  • An x64-based version of Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix. This is because the Lsass.exe file must reload.

Hotfix replacement information

This hotfix replaces the hotfix that is documented in the following Microsoft Knowledge Base article:
907868� An access violation is generated when a Linux-based client computer tries to access a domain controller that is running Windows Server 2003 or Windows 2000

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
Collapse this tableExpand this table
File NameFile VersionFile SizeDateTimePlatform
Ntdsa.dll5.2.3790.27371,521,15230-Jun-200615:12x86
W03a2409.dll5.2.3790.273726,62430-Jun-200611:24 x86
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File NameFile VersionFile SizeDateTimePlatform
Ntdsa.dll5.2.3790.27372,966,01630-Jun-200615:39x64
W03a2409.dll5.2.3790.273727,13630-Jun-200615:39x64
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File NameFile VersionFile SizeDateTimePlatform
Ntdsa.dll5.2.3790.2737 4,251,64830-Jun-200615:39IA-64
W03a2409.dll5.2.3790.2737 25,60030-Jun-200615:39IA-64

Windows Server 2000 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running Windows Server 2000.

Restart requirement

You must restart the computer after you apply this hotfix. This is because the Lsass.exe file must reload.

Hotfix replacement information

This hotfix replaces the hotfix that is documented in the following Microsoft Knowledge Base article:
907868� An access violation is generated when a Linux-based client computer tries to access a domain controller that is running Windows Server 2003 or Windows 2000

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File NameFile VersionFile SizeDateTimePlatform
Ntdsa.dll5.0.2195.7100 938,76827-Jun-200608:20x86
Sp3res.dll5.0.2195.7087 6,401,02403-May-200606:57x86
Updspapi.dll6.2.29.0 371,42413-Oct-200505:59x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
816915� New file naming schema for Microsoft Windows software update packages
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbwinserv2003presp2fix, kbbug, kbfix, kbHotfixServer, kbqfe, kbwin2000presp5fix, KB920919

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Article Info
Article ID : 920919
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 268