Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

ISA Server 2004 Enterprise Edition may stop responding if the firewall does not go into lockdown mode when MSDE logging fails


View products that this article applies to.

Symptoms

If MSDE logging is enabled, and you change the default behavior that puts the firewall into lockdown mode and stops the Microsoft Firewall service when logging fails, Microsoft Internet Security and Acceleration (ISA) Server 2004, Enterprise Edition might start accumulating log records in memory and eventually stop responding in heavy traffic.

↑ Back to the top


Cause

By default, when logging fails, ISA Server automatically goes into lockdown mode and stops the Microsoft Firewall Service. This problem occurs if you change this default behavior by using either of the following procedures:
  • You disable "Stop selected services settings" on the Log Failure alert properties. To check this setting in ISA Server Management, follow these steps:
    1. Click the Monitoring node, and then click the Alerts tab.
    2. In the Task pane, click Configure Alert Definitions.
    3. Double-click the Log Failure alert, and verify that the Stop selected services checkbox is selected under the Actions tab.
  • You run the DisableLockdownOnLogFailure.vbs script that is available at the following Microsoft TechNet Web site:

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

ISA Server 2004 Service Pack 2 (SP2) must be installed before you install this hotfix.

Restart requirement

The following services are automatically stopped and then restarted when you install this hotfix:
  • Microsoft Firewall
  • ISA Server Control
  • ISA Server Job Scheduler
  • ISA Server Storage

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Comphp.dll4.0.3443.618167,78413-Jun-200618:43x86
Complp.dll4.0.3443.61863,33613-Jun-200618:43x86
msfpc.dll4.0.3443.618377,19213-Jun-200618:43x86
msfpccom.dll4.0.3443.6185,024,10413-Jun-200618:43x86
ratlib.dll4.0.3443.61840,80813-Jun-200618:43x86
msfpcsnp.dll4.0.3443.6184,656,48813-Jun-200618:43x86
mspadmin.exe4.0.3443.618282,98413-Jun-200618:43x86
msphlpr.dll4.0.3443.618405,35213-Jun-200618:43x86
mspmon.dll4.0.3443.61852,58413-Jun-200618:43x86
mspmsg.dll4.0.3443.618254,31213-Jun-200618:43x86
rpcfltr.dll4.0.3443.618130,92013-Jun-200618:43x86
w3filter.dll4.0.3443.618750,95213-Jun-200618:43x86
wspsrv.exe4.0.3443.6181,065,83213-Jun-200618:43x86

↑ Back to the top


To resolve this problem in ISA Server 2004, Standard Edition, see the following Microsoft Knowledge Base article:
922946 ISA Server 2004 Standard Edition may stop responding if the firewall does not go into lockdown mode when MSDE logging fails

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB920893, kbbug, kbfix, kbqfe, kbHotfixServer, kbisaserv2004eesp3fix, kbautohotfix, kbarchive, kbnosurvey

↑ Back to the top

Article Info
Article ID : 920893
Revision : 3
Created on : 1/15/2015
Published on : 1/15/2015
Exists online : False
Views : 302