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Error message when Exchange Server 2003 tries to retrieve compressed content in an ISA 2004 organization: "The request is not supported"


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Symptoms

When Microsoft Exchange Server 2003 tries to retrieve compressed content in a Microsoft Internet Security and Acceleration (ISA) Server 2004 organization, you may receive the following error message:
Error Code: 500 Internal Server Error. The request is not supported.

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Cause

This issue may occur when either of the following conditions is true:
  • You receive compressed content through an ISA Server 2004 Web publishing rule or server publishing rule.
  • You try to download .zip file attachments from a Microsoft Outlook Web Access Web site that is published in ISA Server 2004.
ISA Server 2004 does not accept encoded or compressed content when a "Publish a Web Server" rule is used. By default, this rule instructs ISA Server 2004 to delete all "Accept-Encoding" headers from requests that are sent to the Web server. The Web server can still send a compressed response. However, the ISA Server computer does not forward the response to the client. Therefore, the client computer receives the error message.

When a mail server publishing rule is used, the rule enables the ISA Server computer to forward "Accept-Encoding" headers from clients to a Web server. If a client sends an "Accept-Encoding" header that states that the client will accept compressed content, the published Web server may send a compressed response. This is indicated by the response's "Content-Encoding" header. This header is accepted by the ISA Server computer and then forwarded to the client.

Note The ISA Server computer does not cache the compressed content.

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Resolution

To resolve this issue, delete the current Web server publishing rule for the site. Then, run the Publish a Mail Server wizard by using the Outlook Web Access option.

To delete a Web server publishing rule in ISA Server 2004, follow these steps:
  1. Start the ISA Server Management snap-in.
  2. In the navigation tree in the left pane, click Firewall Policy.
  3. Under Firewall Policy, right-click the policy that you want to delete, and then click Delete.
  4. Click Yes, click Apply, and then click OK.
To run the Publish a Mail Server wizard by using the Outlook Web Access option, follow these steps:
  1. Start the ISA Server Management snap-in.
  2. In the right pane, click the Tasks tab, and then click Publish a Mail Server under Firewall Policy Tasks
  3. On the Select access type page, click Web client access: Outlook Web Access (OWA), Outlook Mobile Access, Exchange Server ActiveSync, and then click Next.
  4. On the Select services page, click to select the Outlook Web Access check box, and then click Next.
  5. On the pages that follow, follow the instructions to complete the Publish a Mail Server wizard.

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More information

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
837865 You receive a "The request was rejected by the HTTP Security filter" error message when you try to open a message from an Exchange Server that is published in ISA Server 2004
896367 Windows Server 2003 Service Pack 1 application compatibility

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Keywords: KB920856, kbprb, kbtshoot

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Article Info
Article ID : 920856
Revision : 4
Created on : 12/4/2007
Published on : 12/4/2007
Exists online : False
Views : 315