Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you visit the WSUS Administrator Web page: "One or more Update Service components could not be contacted. Check your server status and ensure that the Windows Server Update Service is running"


Symptoms

When you visit the Microsoft Windows Server Update Services (WSUS) Administrator Web page, you receive an error message that resembles the following:
One or more Update Service components could not be contacted. Check your server status and ensure that the Windows Server Update Service is running. Non-running services: SelfUpdate.
Additionally, you experience the following symptoms:
  • The following error message is logged in the System event log:
  • The W3SVC log files contain the following error log entry:
    2005-08-09 20:25:56 128.231.210.123 GET /selfupdate/iuident.cab - 80 - 128.231.210.123 - 403 6 0
  • The Software Distribution log files contain the following error log entries:
    2005-08-09 20:30:58.021 UTCInfowsusservice.156ThreadEntrySusEventDispatcher.OnSelfUpdateStatusWatchTimer


    2005-08-09 20:30:58.021 UTCWarningwsusservice.156SusEventDispatcher.CheckSelfUpdateTreeRetried 3 times but still received error when checking for SelfUpdate Tree. Error: System.Net.WebException: The remote server returned an error: (403) Forbidden. at System.Net.HttpWebRequest.CheckFinalStatus() at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult) at System.Net.HttpWebRequest.GetResponse() at Microsoft.UpdateServices.Internal.SusEventDispatcher.CheckSelfUpdateTree()

↑ Back to the top


Cause

This problem occurs because the directory security settings for the WSUS server default Web site contain an IP address restriction. This restriction denies the server's IP address access to the WSUS Web site.

↑ Back to the top


Resolution

To resolve this problem, remove the IP address restriction. To do this, follow these steps:
  1. Click Start, click Run, type inetmgr, and then click OK.
  2. In the left pane, expand computer_name, and then expand Web Sites.
  3. Right-click the WSUS Administration Web site, and then click Properties.
  4. Click the Directory Security tab, and then click Edit in the IP address and domain name restrictions area.
  5. Click Granted access, and then click OK two times.

↑ Back to the top


Keywords: kb, kbtshoot, kbentirenet

↑ Back to the top

Article Info
Article ID : 920654
Revision : 9
Created on : 8/20/2020
Published on : 8/20/2020
Exists online : False
Views : 104