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A downloaded .xfd file is empty when you use Outlook Web Access to access a mailbox on a computer that is running Exchange Server 2003 Service Pack 2


View products that this article applies to.

Symptoms

You use Microsoft Outlook Web Access to access a mailbox on a computer that is running Microsoft Exchange Server 2003 Service Pack 2. When you download an .xfd file attachment, and you try to open the file, the downloaded file is empty.

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Cause

This problem occurs because Exchange Server 2003 does not recognize the file type.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, you must have Microsoft Exchange Server 2003 Service Pack 2 (SP2) installed to apply this hotfix.

Restart requirement

When you apply this hotfix, the IIS Admin Service, the Microsoft Search service, the Microsoft Exchange Information Store service, and any dependent services are automatically restarted.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Exosal.dll6.5.7651.3270,14422-Jun-200623:42x86
Mdbmsg.dll6.5.7651.323,361,28022-Jun-200623:00x86
Store.exe6.5.7651.325,258,24022-Jun-200623:45x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

When you access a file by using Outlook Web Access, Exchange Server 2003 verifies the file name extension. If the extension is a known HTML or XML extension, the content is sent to the client. However, if the extension is an XML file that has an unknown file name extension such as .xfd, the content is not sent to the client. Files that have .xfd extensions are secured forms data that is stored in XML format.

After this hotfix is installed, you can configure a list of additional file name extensions that are enabled through the following registry value:

Location:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Value: AttachExtensionAllowed
Type: STRING

Note Use the following format for additional file name extensions: .xxx. The following are examples of the format:
  • .xfd
  • .myext1
  • .myext2
This hotfix is case-sensitive. In the new registry entry on the Exchange server, you must provide all cases for the file name extensions that you want to receive. For example, you may want to receive a file type with the file name extension ".xyz." To do this, you must list all the following case-sensitive file name extensions:
  • .XYZ
  • .XyZ
  • .Xyz
  • .XYz
  • .xYZ
  • .xyZ
  • .xYz

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References

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
817903 New naming schema for Exchange Server software update packages

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Keywords: KB919884, kbpubtypekc, kbbug, kbfix, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 919884
Revision : 3
Created on : 10/28/2008
Published on : 10/28/2008
Exists online : False
Views : 309