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Computers that are running x64-based versions of Windows Server 2003 cannot load a registry hive that is larger than 32 MB


View products that this article applies to.

Symptoms

When you try to start a computer that is running an x64-based version of Microsoft Windows Server 2003, you may receive an error message that resembles the following:
Windows could not start because the following file is missing or corrupt:
\WINDOWS\SYSTEM32\CONFIG\SYSTEM

You can attempt to repair this file by starting Windows Setup using the original Setup CD-ROM.
Select 'r' at the first screen to start repair.
This problem occurs when the system hive is larger than 32 MB.

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Cause

This problem occurs because of a code defect in x64-based versions of Windows Server 2003. The size limit of the system hive for x64-based versions of Windows Server 2003 is set to 32 MB instead of 200 MB.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, 64-bit x64-based versions
File nameFile versionFile sizeDateTime
Ntkrnlmp.exe5.1.2600.2908726,01606-Jun-200618:58
Ntoskrnl.exe5.1.2600.2908132,60806-Jun-200618:58
Windows Server 2003, 64-bit Itanium-based versions
File nameFile versionFile sizeDateTime
Lsasrv.dll5.1.2600.2908726,01614-May-200608:30

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about the size limits of system hives in Windows Server 2003-based operating systems, click the following article number to view the article in the Microsoft Knowledge Base:
302594 The system hive memory limitation is improved in Windows Server 2003

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

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Keywords: KB919807, kbqfe, kbwinserv2003sp2fix, kbautohotfix

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Article Info
Article ID : 919807
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 263