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Error message when you try to print reports in Inventory in Microsoft Dynamics SL: "System Message 6812"


View products that this article applies to.

Symptoms

When you try to print reports in Inventory in Microsoft Dynamics SL or in Microsoft Business Solutions - Solomon, you receive the following error message:
System Message 6812 - You do not have proper access rights for this screen.

You may receive this error message when you try to print any one of the following reports:
  • Inventory Items (10.600.00)
  • Inventory Status (10.610.00)
  • Inventory Trial Balance (10.630.00)
  • Inventory Trial Balance/Valuation Variance (10.640.00)
  • Product Classes (10.700.00)
  • Sales by Inventory ID (10.720.00)
  • Sales by Product Class (10.730.00)
Note If you click OK on this error message, the report prints successfully.

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Cause

This problem occurs if the Check for Missing History (10.602.00) run-before application record is missing from the Screen table in the system database. In this situation, you cannot grant view-level rights to a user for the Check for Missing History (10.602.00) run-before application.

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Resolution

Note Before you follow the instructions in this article, make sure that you have a complete backup copy of the database that you can restore if a problem occurs.
To resolve this problem, add the Check for Missing History (10.602.00) run-before application record to the Screen table in the system database. Then, grant view-level rights to the user. To do this, follow these steps:
  1. Run the following statement in Microsoft SQL Query Analyzer against the system database.
    INSERT INTO SCREEN (Module, Name, Number, ScreenType) 
    Values ('IN','Check for Missing History ', '1060200', 'S')
  2. Grant view-level rights to the user for the Check for Missing History (10.602.00) run-before application. To do this, follow these steps:
    1. On the Utility menu, click Access Rights.
    2. In the Group/User ID box, type the user ID.
    3. In the Company ID box, type the company ID. Or, click to select the All Companies check box.
    4. In the Detail area, type 1060200 in the Screen/Report Number box. Then, press the TAB key.

      The value Check for Missing History appears in the Name box.
    5. Verify that the View check box is selected.
    6. Click Save, and then close the Access Rights Maintenance (98.270.00) screen.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem has been reported as issue 6189. If a hotfix is available, you can find the hotfix in the Downloads & Updates section of PartnerSource or in the Downloads & Updates section of CustomerSource. If you do not find a hotfix for this issue in PartnerSource or in CustomerSource, search the "Summary of Changes" document for the next Microsoft release or for the next service pack. The "Summary of Changes" document lists the changes that have been made in the release or in the service pack.

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Keywords: kbexpertiseadvanced, kbexpertiseinter, kbmbsenvironment, kbmbspartner, kberrmsg, kbmbsmigrate, kbbug, kb

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Article Info
Article ID : 919766
Revision : 2
Created on : 2/2/2017
Published on : 2/3/2017
Exists online : False
Views : 499