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A picklist field returns no values when you add a picklist field in the associated view of a custom entity in Microsoft Dynamics CRM 3.0


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Symptoms

When you add a picklist field in the associated view of a custom entity in Microsoft Dynamics CRM 3.0, the picklist field returns no values.

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Cause

This problem occurs when you use a reserved word, such as "area" or "relationship," in the schema name of a custom entity. Additionally, this problem occurs only when the schema name follows this pattern:
Prefix_ReservedWordAdditionalCharacters
For example, the problem occurs if the schema name is "new_areas" or "new_areasOfInterest."

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Resolution

To resolve this problem, follow one of these guidelines:
Do not use a reserved word in the schema name of a custom entity.
If you must use a reserved word in the schema name, add an additional underscore or other characters in front of the reserved word. For example, you can use "new__areas" and "new__areasOfInterest" as schema names.

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Status

This problem was corrected in Microsoft Dynamics CRM 4.0.

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Keywords: KB919645, kbprb, kbmbsmigrate, kbmbscustomization, kbtshoot

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Article Info
Article ID : 919645
Revision : 2
Created on : 1/7/2008
Published on : 1/7/2008
Exists online : False
Views : 324