Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: COM+ applications that run on a Windows Server 2003-based computer may stop responding because a deadlock condition occurs in the COM+ System Application service


View products that this article applies to.

Symptoms

Microsoft COM+ applications that run on a Microsoft Windows Server 2003-based computer may stop responding (hang) because a deadlock condition occurs in the COM+ System Application service.

↑ Back to the top


Cause

This problem occurs because a race condition occurs that involves calls to the DeleteTimerQueueTimer method. Any COM+ applications that call into the COM+ System Application service may stop responding.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

↑ Back to the top


Workaround

To work around this problem, restart the COM+ System Application service. To do this, follow these steps:
  1. Click Start, click Run, type services.msc, and then click OK.
  2. Right-click COM+ System Application, and then click Restart.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about the DeleteTimerQueueTimer method, visit the following Microsoft Developer Network (MSDN) Web site:

↑ Back to the top


Keywords: kbwinserv2003sp2fix, kbfix, kbhotfixrollup, kbqfe, kbpubtypekc, kbprb, KB919303

↑ Back to the top

Article Info
Article ID : 919303
Revision : 7
Created on : 12/5/2007
Published on : 12/5/2007
Exists online : False
Views : 405