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You receive an error message when you try to apply a tracking profile in the Tracking Profile Editor in BizTalk Server 2006


Symptoms

When you try to apply a tracking profile in the Tracking Profile Editor in Microsoft BizTalk Server 2006, you may receive an error message that resembles one of the following:

Message 1
Exception Details: System.Runtime.InteropServices.COMException: The transaction has already been implicitly or explicitly committed or aborted
Message 2
Exception Details: Communication with the underlying transaction manager has failed. (System Transactions)
Message 3
Exception Details: Unhandled Exception: System.InvalidOperationException: The Promote method returned an invalid value for the distributed transaction.
This issue can occur when BizTalk Server 2006 is running on an x64-based computer.

Note BizTalk Server 2006 Standard Edition is supported on an x64 operating system. However, BizTalk Server 2006 Standard Edition is not supported in native 64-bit execution. For more information about 64-bit support in BizTalk Server 2006, visit the following Microsoft Developer Network (MSDN) Web site:

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Cause

This issue can occur if one or more of the following conditions are true:
  • The Microsoft Distributed Transaction Coordinator (MSDTC) service cannot be initialized. This occurs if a lightweight remote procedure call (LRPC) association contains an incorrect Service Principal Name (SPN) in its authentication information structure because of the Winspool.drv file.
  • The Tracking Profile Editor tries to use RPC to connect to the MSDTC transaction coordinator. When this occurs, the interface may perform additional security checks.

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To resolve this issue, install the hotfix that is described in the following Microsoft Knowledge Base article.For more information, click the following article number to view the article in the Microsoft Knowledge Base:

910907 You may receive error messages when you run a 32-bit program on a 64-bit Windows Server 2003-based computer

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Workaround

To work around this issue, use one of the following methods:

Important These steps may increase your security risk. These steps may also make the computer or the network more vulnerable to attack by malicious users or by malicious software such as viruses. We recommend the process that this article describes to enable programs to operate as they are designed to or to implement specific program capabilities. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this process in your particular environment. If you decide to implement this process, take any appropriate additional steps to help protect the system. We recommend that you use this process only if you really require this process.

Method 1: Use the Group Policy Object Editor

Use the Group Policy Object Editor to disable the RestrictRemoteClients setting that the RPC configuration enforces:
  1. Click Start, click Run, type Gpedit.msc, and then click
    OK.
  2. Expand Computer Configuration, expand
    Administrative Templates, expand System, and then click Remote Procedure Call.
  3. In the right pane, double-click Restrictions for Unauthenticated RPC Clients.
  4. Click Disabled, and then click
    OK.

Method 2: Use Registry Editor

On a BizTalk configuration with a single server, use Registry Editor to disable the RestrictRemoteClients setting that the RPC configuration enforces:
  1. Click Start, click Run, type Regedit, and then click
    OK.
  2. Locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT
  3. On the Edit menu, point to
    New, and then click Key.

    Note If the RPC registry key already exists, go to step 5.
  4. Type RPC, and then press ENTER.
  5. Click RPC.
  6. On the Edit menu, point to
    New, and then click DWORD Value.
  7. Type RestrictRemoteClients, and then press ENTER.
  8. Click RestrictRemoteClients.
  9. On the Edit menu, click
    Modify.
  10. In the Value data box, type 0, and then click
    OK.

    Note To enable the RestrictRemoteClients setting, type1.
  11. Close Registry Editor.

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More Information

When the Tracking Profile Editor tries to connect to the MSDTC on the local computer, the interface that is used may perform additional security checks. Depending on the operating system version and service packs that are installed on the computer, RPC may perform these additional security checks when the interface does not have a registered security callback.

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References

For more information about issues that can occur when you run a 32-bit program on a 64-bit Windows Server 2003-based computer, click the following article number to view the article in the Microsoft Knowledge Base:

910907 You may receive error messages when you run a 32-bit program on a 64-bit Windows Server 2003-based computer


For more information about the RestrictRemoteClients setting, visit the following Microsoft Web site:

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Article Info
Article ID : 919216
Revision : 1
Created on : 3/25/2017
Published on : 9/23/2011
Exists online : False
Views : 1011