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Error message when you try to install Microsoft Dynamics CRM Mobile 3.0: "Error 1609. An error occurred while applying security settings"


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Symptoms

When you try to install Microsoft Dynamics CRM Mobile 3.0, you may receive the following error message:
Error 1609. An error occurred while applying security settings.
Domain\UserGroup is not a valid user or group.
This could be a problem with the package, or a problem connecting to a domain controller on the network.
Check your network connection and click Retry, or Cancel to end the install.
Note In this error message, Domain represents an actual domain name.
This problem occurs when one of the following conditions is true:
  • Microsoft Dynamics CRM 3.0 was upgraded from Microsoft CRM 1.2.
  • When you installed Microsoft Dynamics CRM 3.0, you used customized security groups in Active Directory.
Note To install Microsoft Dynamics CRM Mobile 3.0, you must perform the installation at the Microsoft Dynamics CRM 3.0 server.

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Cause

Cause 1

This problem occurs because the UserGroup name does not have a suffix that is the organization identifier (ID). The UserGroup name must have this ID as a suffix when you perform either of the following actions:
  • You upgrade from Microsoft CRM 1.2 to Microsoft Dynamics CRM 3.0.
  • You install Microsoft Dynamics CRM 3.0 by using customized security groups.

Cause 2

There are two groups that are named "UserGroup" in the Active Directory Users and Computers snap-in. One group is a member of the other group.

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Resolution

To resolve this problem, follow these steps:
  1. Download the Microsoft Dynamics CRM Mobile User Group Repair Tool. To obtain the tool, visit the following Microsoft Web site:
  2. Log in to Microsoft SQL Server as a user who has Microsoft SQL Server administrator permissions.
  3. Click Start, point to Programs, point to Microsoft SQL Server, and then click Query Analyzer.
  4. In the Connect to SQL Server dialog box, select the computer that is running Microsoft SQL Server in the SQL Server list, and then click OK.
  5. Click Organization_Name_MSCRM in the database list.
    Note In this name, Organization_Name represents an actual organization.
  6. In the Query box, type the following command:
    select organizationid from organizationbase
  7. On the Query menu, click Execute.
  8. In the Query box, note the returned value.
    Note The returned value is an organization ID.
  9. Click Start, click Run, type dsa.msc, and then click OK to open the Active Directory Users and Computers dialog box.
  10. In the Users list, right-click the UserGroup group that has a Type setting of Security Group, and then click Rename.
  11. Change the UserGroup name to include a suffix that is the organization ID. The organization ID is the value that you noted in step 8. For example, change the UserGroup name to the following name:
    UserGroup {5c83c13c-88db-485a-a9a4-720fb07278b4}
  12. Press ENTER.
  13. In the Rename Group dialog box, click OK.
  14. Repeat step 10 through step 13 for the SQLAccessGroup group that has a Type setting of Security Group.
  15. Re-install Microsoft Dynamics CRM Mobile 3.0.

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Keywords: KB918430, kbprb, kbmbsmigrate, kberrmsg, kbtshoot, kbmbsupgrade, kbmbscrm40no

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Article Info
Article ID : 918430
Revision : 6
Created on : 9/7/2006
Published on : 9/7/2006
Exists online : False
Views : 349