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Error message in Web parts when you use Business Portal in Microsoft Dynamics GP or in Microsoft Dynamics SL: "CurrentPrincipal is not authenticated"


Symptoms

When you use Business Portal in Microsoft Dynamics SL or in Microsoft Dynamics GP, you receive the following error message in Web parts:
CurrentPrincipal is not authenticated

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Cause

This problem occurs when anonymous access is enabled for either the Business Portal Web site or the BusinessPortal virtual directory.

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Resolution

To resolve this problem, follow these steps:
  1. In Microsoft Internet Information Services (IIS) Manager, right-click the Business Portal Web site. Then, click Properties.
  2. On the Directory Security tab, click Edit in the Authentication and Access Control section.
  3. Click to clear the Enable Anonymous Access check box if it is selected.
  4. Click Apply, and then click OK.

    Note If you are prompted to roll the changes down to all child nodes, click Select All, and then click OK.
  5. Expand the Business Portal Web site, right-click the BusinessPortal virtual directory, and then click Properties.
  6. On the Directory Security tab, click Edit in the Authentication and Access Control section.
  7. Click to clear the Enable Anonymous Access check box if it is selected.
  8. Click Apply, and then click OK.

    Note If you are prompted to roll the changes down to all child nodes, click Select All, and then click OK.

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Keywords: kbnosurvey, kberrmsg, kbsolomonbp, kbgreatplainsbp, kbmbsmigrate, kbprb, kb

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Article Info
Article ID : 918260
Revision : 1
Created on : 3/25/2017
Published on : 1/3/2015
Exists online : False
Views : 101