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You may be unable to use a disk volume after you perform a hardware restoration or a software restoration of the disk volume in Microsoft Windows Server 2003


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Symptoms

After you restart a computer, you may be unable to use a disk volume. This problem occurs after you perform a hardware restoration or a software restoration of the disk volume.

When you run the Diskpart.exe utility, the utility shows the following:
  • The read-only attribute flags are set on the disk volume.
  • The hidden attribute flags are set on the disk volume.
This problem may occur when either of the following conditions is true:
  • A low-level restoration of the disk data contains read-only attribute flags or hidden attribute flags.
  • You have performed a hardware-level disk swap, and read-only attribute flags or hidden attribute flags are set on the disk.

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Cause

This problem occurs when a restoration process is set to change the attribute flags of a disk volume. Because the attribute flags are cached when the disk and the volumes are mounted, the restoration process can change only the cached information. This restriction helps prevent an unexpected event such as a computer restart from making the volumes inaccessible. However, if you restore the on-disk data, or if you perform a hardware swap of the disks to do a snapshot restoration, the on-disk attribute flags may be set. Therefore, you may be unable to access the disk after the computer restarts. Before the computer restarts, any queries of the attribute flags return the cached flags.

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Workaround

To work around this problem, reset to zero any component that performs a restoration process that involves any of the following functions:
  • Swapping disks
  • Setting on-disk data that contains read-only attribute flags after the restoration finishes
  • Setting on-disk data that contains hidden attribute flags after the restoration finishes
Note To enable the restoration on a physical disk, the cached flags of the disk or of the volumes persist in server clusters that use extended maintenance mode. However, the on-disk and cached flags may not be consistent. To make sure that the on-disk flags and the cached flags are consistent when a restoration process is complete, we recommend that you reset the following flags to zero:
  • GPT_BASIC_DATA_ATTRIBUTE_NO_DRIVE_LETTER
  • GPT_BASIC_DATA_ATTRIBUTE_HIDDEN
  • GPT_BASIC_DATA_ATTRIBUTE_READ_ONLY

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More information

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
840781 New Diskpart.exe commands to reset volume attribute flags on failed snapshot volumes in Windows Server 2003
903650 Extended maintenance mode functionality for cluster physical disk resources in Windows Server 2003

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References

For help with common system maintenance tasks in Windows Vista, visit the following Microsoft Web page:

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Keywords: KB918188, kbtshoot

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Article Info
Article ID : 918188
Revision : 3
Created on : 10/29/2009
Published on : 10/29/2009
Exists online : False
Views : 201