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The Add Printer Wizard or the Printer dialog box stop responding on a Windows Server 2003-based, Windows XP-based, or Windows 2000-based computer


View products that this article applies to.

Symptoms

You may experience one or more of the following printer issues on a computer that is running Microsoft Windows Server 2003, Microsoft Windows XP, or Microsoft Windows 2000:
  • When you try to open the Print dialog box, it takes a long time to open.
  • When you use the Add Printer Wizard to install a network printer that is hosted on a server that is running the SMB Service, the Add Printer Wizard may stop responding. The problem occurs after the driver files are copied.
  • When you select a different network printer in the Printer Name box in the Add Printer Wizard, there may a delay before the change is applied. This problem may occur even though the conditions in the "Cause" section do not apply to the network printer that you select.

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Cause

This problem occurs because of a bug in the spooler (spoolss.dll). This problem occurs if the following conditions are true:
  • The size of the DEVMODE structure that is used by the printer driver is larger than 4,096 bytes.
  • The name of the printer has an odd number of characters. For example, in the following network printer name, MyPrinterName contains an odd number of characters (13):
    \\SMBPrinterServer\MyPrinterName
    The problem does not occur if the name of the printer has an even number of characters.

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Resolution

Windows Server 2003 service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Windows Server 2003 hotfix information

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1)installed on the computer.

Note Windows Server 2003, x64-based versions do not require Windows Server 2003 SP1 to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Spoolss.dll5.2.3790.2805167,93604-Oct-200617:31x64
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Spoolss.dll5.2.3790.2805253,95204-Oct-200617:32IA-64
Windows Server 2003, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Spoolss.dll5.2.3790.280587,55204-Oct-200617:15x86

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Spoolss.dll5.1.2600.300874,75204-Oct-200617:13x86

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Status

Windows 2000

To work around this problem in Windows 2000, use an even number of characters for the name of the printer.

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More information

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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Keywords: kbautohotfix, kbwinserv2003presp2fix, kbbug, kbfix, kbqfe, kbHotfixServer, KB917777

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Article Info
Article ID : 917777
Revision : 4
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 283