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You cannot view a sales account, a lead, or an opportunity that is owned by another user in the Turkish version of Microsoft Dynamics CRM 3.0


View products that this article applies to.

Symptoms

When you log on as a user who has the SalesPerson role and then try to view a sales account, a lead, or an opportunity that is owned by another user, the sales account, the lead, or the opportunity does not open. This problem occurs in the Turkish version of Microsoft Dynamics CRM 3.0.

The following error message is logged in the Application event log on the server that is running Microsoft CRM:

Error Description:
Exception from HRESULT: 0x80044150.

Error Details:
Exception from HRESULT: 0x80044150.

Error Number:
0x80044150

Source File:
Not available

Line Number:
Not available

Date: date
Time: time

Type: Platform Error (3)
Server: IP address
Request URL: URL

Additionally, if the DevErrors parameter is enabled in the Web.config file, you receive the following error message.

Note You may receive this error message when the user is assigned a role that has permissions to view a sales account, a lead, or an opportunity that is owned by another user.
Microsoft CRM Unhandled Error
Details: Server Error in '/' Application.

Exception from HRESULT: 0x80044150.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: Exception from HRESULT: 0x80044150.

Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace: [COMException (0x80044150): Exception from HRESULT: 0x80044150.] Microsoft.Crm.Platform.ComProxy.CRMAccountClass.RetrievePrincipalAccess(CUserAuth& Caller, String AccountId, CSecurityPrincipal& Principal) +0 Microsoft.Crm.Application.Platform.Account.InternalGetPrivileges(String id, CSecurityPrincipal& securityPrincipal) +36 Microsoft.Crm.Application.Platform.Entity.GetPrivileges(CSecurityPrincipal securityPrincipal) +34 Microsoft.Crm.Security.PrivilegeCheck.Execute(User user, Entity entity) +246 Microsoft.Crm.Security.PrivilegeCheckFactory.CreatePrivilegeCheck(User user, Entity entity) +105 Microsoft.Crm.Application.Forms.EndUserForm.RetrieveDataParams() +24 Microsoft.Crm.Application.Forms.EndUserForm.Initialize(Entity entity) +67 Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity, String formId, String formType) +83 Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity) +13 Microsoft.Crm.Web.SFA.AccountDetailPage.ConfigureForm() +238 Microsoft.Crm.Application.Controls.AppPage.OnPreRender(EventArgs e) +30 System.Web.UI.Control.PreRenderRecursiveInternal() +62 System.Web.UI.Page.ProcessRequestMain() +1499

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Cause

This problem may occur when a query for a sales account, a lead, or an opportunity on a computer that is running Microsoft SQL Server contains the letters "I" or "i". The letters "I" and "i" are evaluated differently when you use a Turkish collation in Microsoft SQL Server. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
279651 ADO Recordset field name with letter "i" is case sensitive with Turkish settings

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Resolution

This problem is fixed in Microsoft Dynamics CRM 3.0 Update Rollup 1. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
922815 Update Rollup 1 is available for Microsoft Dynamics CRM 3.0

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More information

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
887283 Microsoft Business Solutions CRM software hotfix and update package naming standards
For more information about how to modify the Web.config file to show more detailed error messages, click the following article number to view the article in the Microsoft Knowledge Base:
857192 How to modify the Web.config file to show more detailed error messages in Microsoft CRM

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Keywords: KB917602, kbmbsmigrate, kbhotfixserver, kbqfe, kbbug, kberrmsg, kbcrmv3cno

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Article Info
Article ID : 917602
Revision : 6
Created on : 1/24/2007
Published on : 1/24/2007
Exists online : False
Views : 427