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Error message when you try to use the Microsoft Exchange Server ActiveSync Web Administration tool to delete a partnership or to perform a Remote Wipe operation on a mobile device in Exchange Server 2003 SP2: "(401) Unauthorized"


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Symptoms

When you try to use the Microsoft Exchange Server ActiveSync Web Administration tool to delete a partnership with a mobile device or to perform a Remote Wipe operation on a mobile device, you receive the following error message:
Failed to access user's Mailbox, verify that the mailbox and user account are enabled and functional.
Server Error in '/MobileAdmin' Application.

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The remote server returned an error: (401) Unauthorized.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Net.WebException: The remote server returned an error: (401) Unauthorized.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[WebException: The remote server returned an error: (401) Unauthorized.]
System.Net.HttpWebRequest.CheckFinalStatus() +680
System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult) +74
System.Net.HttpWebRequest.GetRequestStream() +234
Microsoft.Exchange.AirSync.Admin.Mailbox.propFindRequest(String deviceUri) +240
Microsoft.Exchange.AirSync.Admin.Mailbox.getDevices() +194
Microsoft.Exchange.AirSync.Admin.Devices.refreshDevicesTable() +135
Microsoft.Exchange.AirSync.Admin.Devices.Page_Load(Object sender, EventArgs e) +190
System.Web.UI.Control.OnLoad(EventArgs e) +67
System.Web.UI.Control.LoadRecursive() +35
System.Web.UI.Page.ProcessRequestMain() +750

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Version Information: Microsoft .NET Framework Version:1.1.4322.2300; ASP.NET Version:1.1.4322.2300

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Cause

This issue occurs if one or both of the following conditions are true:
  • Integrated Windows authentication is not enabled on the Exadmin virtual directory on the mailbox server.

    Note In a front-end/back-end (FE/BE) Exchange configuration, this issue occurs if Integrated Windows authentication is not enabled on the Exadmin virtual directory on the back-end server.
  • The MobileAdmin Web application is not running under the ExchangeApplicationPool application pool.

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Resolution

To resolve this issue, follow these steps.

Step 1: Verify the authentication method that is used on the Exadmin virtual directory

Make sure that the mailbox server has the Integrated Windows authentication method set on the Exadmin virtual directory. Integrated Windows authentication must be set on this virtual directory for the Microsoft Exchange Server ActiveSync Web Administration tool to use Kerberos authentication. To verify this setting, follow these steps:
  1. Start the Internet Information Services (IIS) Manager tool. To do this, click Start, point to Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
  2. Expand the Web server, expand Web Sites, and then expand Default Web Site.
  3. Right-click Exadmin, and then click Properties.
  4. Click the Directory security tab, and then click Edit under Authentication and access control.
  5. Click to select the Integrated Windows authentication check box if it is not already selected.
  6. Click OK two times to close the Exadmin Properties dialog box.

Step 2: Verify the application pool under which the MobileAdmin application is running

Verify that the MobileAdmin application is running under the ExchangeApplicationPool application pool in Microsoft Internet Information Services (IIS). To do this, follow these steps:
  1. Start the Internet Information Services (IIS) Manager tool.
  2. Expand the Web server, expand Web Sites, and then expand Default Web Site.
  3. Right-click MobileAdmin, and then click Properties.
  4. Click the Virtual Directory tab.
  5. In the Application pool list, click ExchangeApplicationPool if this option is not already selected.
  6. Click OK.

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More information

To obtain the Microsoft Exchange Server ActiveSync Web Administration tool, visit the following Microsoft Web site:

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Keywords: KB916960, kbprb, kbtshoot

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Article Info
Article ID : 916960
Revision : 3
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 421