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You receive an error message when you try to open a Web page in a UDDI Web site in Windows Server 2003


View products that this article applies to.

Symptoms

You receive an error message in Microsoft Internet Explorer when you try to open a Web page in a Universal Description, Discovery, and Integration (UDDI) Web site and the following conditions are true:
  • You have distributed installations of UDDI on Microsoft Windows Server 2003.
  • You upgrade one server to Windows Server 2003 Service Pack 1 (SP1).
You receive the following error message in Internet Explorer:
Server Error in '/Folder' Application.
--------------------------------------------------------------------------------

Server configuration error. [[UDDI_ERROR_SCHEMA_MISMATCH]]
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: UDDI.UDDIException: Server configuration error. [[UDDI_ERROR_SCHEMA_MISMATCH]]
The following error messages are logged in the Application event log:
Error message 1
Event Type: Error
Event Source: UDDIRuntime
Event Category: Config
Event ID: 200
Date: Date
Time: Time
User: N/A
Computer: ServerName
Description:
The version of the schema being used by the Web server (2.1.1.0) is not compatible with the version of the schema being used by the database server (2.0.1.3).
Error message 2
Event Type: Error
Event Source: UDDIRuntime
Event Category: Config
Event ID: 200
Date: Date
Time: Time
User: N/A
Computer: ServerName
Description:
[[UDDI_ERROR_SCHEMA_MISMATCH]]

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Cause

This problem occurs when the servers in distributed installations of UDDI are not all at the same service pack level.

Note The servers must be at the same service pack level for supported distributed installations of UDDI. In these installations, the UDDI Web component is installed on one server and the UDDI database component is installed on another server or on a cluster.

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Resolution

To resolve this problem, update or roll back all servers that are involved with the UDDI installation to the same service pack level.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about UDDI, visit the following Microsoft Web site:

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Keywords: KB916928, kbprb, kbtshoot, kberrmsg, kbbug

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Article Info
Article ID : 916928
Revision : 3
Created on : 5/9/2006
Published on : 5/9/2006
Exists online : False
Views : 237