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Error messages when you send an e-mail message from the Microsoft CRM Web client: "Invalid Visibility Modification Access" and "Invalid Association: The request association is not valid"


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Symptoms

When you send an e-mail message from the Microsoft Dynamics CRM Web client, you receive one or more of the following error messages.
Error message 1
Invalid Visibility Modification Access
Error message 2
Invalid Association: The request association is not valid.

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Cause

This problem may occur for one of the following reasons:
  • During the Microsoft CRM Server setup, Secure Sockets Layer (SSL) was enabled. When SSL is enabled, outgoing e-mail messages use SSL when SSL is not enforced by Microsoft Exchange Server 2003.
  • The Simple Mail Transfer Protocol (SMTP) port for Exchange Server 2003 SMTP traffic has been changed from the default port. The default for the SMTP port is port 25.
  • The default setting in the antivirus software on the Microsoft CRM server blocks mass mailings on port 25.
  • The default SMTP virtual server is not set up to allow for anonymous access.
  • The All Unassigned setting is not enabled for IP addresses on the SMTP server that is used by Microsoft Dynamics CRM. This problem occurs in Microsoft Dynamics CRM environments that use Microsoft Exchange Server for SMTP traffic.

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Resolution

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this problem, use one of the following methods.

Method 1: Confirm that a certificate is installed in Exchange Server 2003

  1. Click Start, point to All Programs, point to Microsoft Exchange, and then click System Manager.
  2. Expand Administrative Groups, and then expand First Administrative Group.

    Note If the administrative groups are not displayed, right-click Organization_Name, click Properties, click to select the Display administrative groups check box, click OK two times, and then restart System Manager. Replace the Organization_Name placeholder with the name of the organization.
  3. Expand Servers, expand Exchange_server, expand Protocols, and then expand SMTP.

    Note Replace the Exchange_server placeholder with the name of the Exchange server.
  4. Right-click Default SMTP Virtual Server, and then click Properties.
  5. In the Default SMTP Virtual Server Properties dialog box, click the Access tab, and then click Certificate.

    Note If there is a certificate installed, SSL is enabled.
  6. Make sure that the Require secure channel check box is selected. If the Require secure channel check box is not selected, the following registry subkey will not be correctly set on the Microsoft CRM server:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  7. Verify that the following registry entries in the subkey are set to the correct value:
    • SMTPAuthenticate (REG_DWORD)
      If SMTP is not required to use SSL, the value of this registry entry should be 0.
    • SMTPServer (REG_SZ)
      This registry entry specifies the Exchange server that is used to send outgoing SMTP e-mail.
    • SMTPServerPort (REG_DWORD)
      This registry entry specifies the port that Exchange SMTP traffic uses. The TCP port number should match the decimal value for this registry entry.
    • SMTPUseSSL (REG_DWORD)
      If SMTP is not required to use SSL, the value of this registry entry should be 0.

Method 2: Modify the SMTPServerPort registry entry to use the correct SMTP port

  1. Click Start, point to All Programs, point to Microsoft Exchange, and then click System Manager.
  2. Expand Administrative Groups, and then expand First Administrative Group.

    Note If administrative groups are not displayed, right-click Organization_Name, click Properties, click to select the Display administrative groups check box, click OK two times, and then restart System Manager. Replace the Organization_Name placeholder with the name of the organization.
  3. Expand Servers, expand Exchange_server, expand Protocols, and then expand SMTP.

    Note Replace the Exchange_server placeholder with the name of the Exchange server.
  4. Right-click Default SMTP Virtual Server, and then click Properties.
  5. Click the Delivery tab, and then click Outbound connections.

    Note The TCP port field displays the port that is used for outgoing traffic.
  6. Click Start, click Run, type regedit, and then click OK.
  7. In Registry Editor, locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  8. Change the decimal value of the SMTPServerPort registry entry so that it matches the port number that is used for outgoing traffic.

    Note The port that is used for outgoing traffic is displayed in the TCP port field in step 5 earlier in this section.

Method 3: Add the W3wp.exe file to the list of the excluded port blocking processes in the antivirus software

For more information about how to add files to the list of the excluded port blocking processes, contact your antivirus software provider.

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Method 4: Verify that the default SMTP virtual server is set up to allow for anonymous access

  1. Click Start, point to All Programs, point to Microsoft Exchange, and then click System Manager.
  2. Expand Administrative Groups, and then expand First Administrative Group.

    Note If administrative groups are not displayed, right-click Organization_Name, click Properties, click to select the Display administrative groups check box, click OK two times, and then restart System Manager.
  3. Expand Servers, expand Exchange_Server, expand Protocols, and then expand SMTP.
  4. Right-click Default SMTP Virtual Server, and then click Properties.
  5. Click the Access tab.
  6. Click Authentication, and then verify that the Anonymous access check box is selected.

Method 5: Enable the All Unassigned setting for IP addresses on the SMTP server that is used by Microsoft Dynamics CRM

  1. Click Start, point to All Programs, point to Microsoft Exchange, and then click System Manager.
  2. Expand Administrative Groups, and then expand First Administrative Group.

    Note If administrative groups are not displayed, right-click Organization_Name, click Properties, click to select the Display administrative groups check box, click OK two times, and then restart System Manager.
  3. Expand Servers, expand Exchange_Server, expand Protocols, and then expand SMTP.
  4. Right-click Default SMTP Virtual Server, and then click Properties.
  5. Click the General tab. In the IP address list, click All Unassigned, and then click OK.
  6. Restart the SMTP service. To do this, follow these steps:
    1. Click Start, click Run, type services.msc, and then click OK.
    2. Right-click Simple Mail Transfer Protocol (SMTP), and then click Restart.

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More information

DevErrors

If you have DevErrors enabled, you also receive the following error message when the problem that is described in the "Symptoms" section occurs:
Server was unable to process request.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
Exception Details: System.Web.Services.Protocols.SoapException: Server was unable to process request.
Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
Stack Trace: SoapException: Server was unable to process request.
System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) +1496
System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) +218
Microsoft.Crm.Platform.Proxy.EmailWebService.Send(Guid emailId, Boolean issueSend, String trackingToken) +132
Microsoft.Crm.Application.SMWrappers.Email.Send(String id, Boolean issueSend, String trackingToken) +93
Microsoft.Crm.Application.Platform.Email.Send() +83 Microsoft.Crm.Web.Activities.EmailDetailPage.Send(Object sender, DataEventArgs e) +83
Microsoft.Crm.Application.Forms.DataEventProcessor.Raise(FormEventId eventId, FormState state, User user, String objectId, Entity entity) +176
Microsoft.Crm.Application.Forms.AppForm.RaiseDataEvent(FormEventId eventId) +89 Microsoft.Crm.Application.Forms.EndUserForm.Initialize(Entity entity) +56 Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity, String formId, String formType) +83
Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity) +13 Microsoft.Crm.Web.Activities.EmailDetailPage.ConfigureForm() +261
Microsoft.Crm.Application.Controls.AppPage.OnPreRender(EventArgs e) +30 System.Web.UI.Control.PreRenderRecursiveInternal() +62
System.Web.UI.Page.ProcessRequestMain() +1499

Platform trace

When you run a platform trace on the Microsoft CRM server after you experience the problem that is described in the "Symptoms" section, you receive the following error message:
0x8004020e

TCP/IP filtering

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
309798 How to configure TCP/IP filtering in Windows 2000
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: KB916925, kbprb, kbmbsmigrate, kbmbsemail, kbtshoot, kbmbscrm40no

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Article Info
Article ID : 916925
Revision : 4
Created on : 3/23/2007
Published on : 3/23/2007
Exists online : False
Views : 446