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Error message when you try to access Reports in Microsoft Dynamics CRM 3.0: "The underlying connection was closed: Could not establish trust relationship with remote server"


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

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Symptoms

When you try to access Reports in Microsoft Dynamics CRM 3.0, you may receive the following error message:
The underlying connection was closed: Could not establish trust relationship with remote server.

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Cause

This problem occurs because Microsoft CRM uses the certificate that you created for the server after you installed or upgraded the program. Microsoft CRM is installed on this server. By default, the installer program uses the Web address that is specified in this certificate. Microsoft CRM reports do not work if you try to access Reports by using this Web address.

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Resolution

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
To resolve this problem, remove the Web address from the report configuration files and from the registry. To do this, follow these steps.

Note This procedure uses the default file locations for Microsoft SQL Server 2000. If you are using Microsoft SQL Server 2005, the files may be in different locations.
  1. On the server on which SQL Server Reporting Services (SSRS) is installed, modify the Rswebapplication.config file. To do this, follow these steps.

    Note You can verify the installation location of Reporting Services by using Microsoft Internet Information Services (IIS) Manager. The Reports folder and the ReportServer folder are listed under the default Web site.
    1. Open the Rswebapplication.config file. By default, this file is in the following location:
      C:\Program Files\Microsoft SQL Server\MSSQL\Reporting Services\ReportManager\
    2. In the file, locate the following section:
      <ReportServerUrl>https://Servername.example_domain.10.com/ReportServer</ReportServerUrl>


      Note In this step and in step c, Servername represents the actual server name, and example_domain.10.com represents an actual domain name.
    3. In the path that is mentioned in step b, change https://Servername.example_domain.10.com to https://Servername.
    4. Save and close the file.
  2. Modify the Rsreportserver.config file. To do this, follow these steps:
    1. Open the Rsreportserver.config file.


      Note By default, this file is in the following location:
      C:\Program Files\Microsoft SQL Server\MSSQL\Reporting Services\ReportServer\
    2. In the file, locate the following section:
      <UrlRoot>https://Servername.example_domain.10.com/ReportServer</UrlRoot>
      Note In this step and in step c, Servername represents the actual server name, and example_domain.10.com represents an actual domain name.
    3. In the path that is mentioned in step b, change https://Servername.example_domain.10.com to https://Servername.
    4. Save and close the file.
  3. Modify the registry for Reporting Services. To do this, follow these steps:
    1. Click Start, click Run, type Regedit, and then click OK.
    2. In Registry Editor, click the following subkey:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\80\Reporting Services
    3. Click Reporting Services.
    4. Right-click RSVirtualDir. Then click Modify.
    5. Change the value that is in the Value data field from https://Servername.example_domain.10.com/ReportServer to https://Servername/ReportServer, and then click OK.

      Note In this step, Servername represents the actual server name, and example_domain.10.com represents an actual domain name.
    6. Right-click WAVirtualDir. Then click Modify.
    7. Change the value that is in the Value data field from https://Servername.example_domain.10.com/Reports to https://Servername/Reports, and then click OK.

      Note In this step, Servername represents the actual server name, and example_domain.10.com represents an actual domain name.
    8. In Registry Editor, click the following subkey:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
    9. Click MSCRM.
    10. Right-click SQLRSServerURL. Then click Modify.
    11. Change the value that is in the Value data field from https://Servername.example_domain.10.com/ReportServer to https://Servername/ReportServer, and then click OK.

      Note In this step, Servername represents the actual server name, and example_domain.10.com represents an actual domain name.
    12. On the File menu, click Exit.
  4. Verify that you can access the SSRS Manager by using the following Web address:
    https://Servername/Reports
    Notes
    • In this step, Servername represents the actual server name.
    • You may receive an error message if you access the SSRS Manager by using the Web address and if you are using Microsoft SQL Server 2005. To resolve this problem, follow the instructions in the following Microsoft Knowledge Base article:
      916163� You receive an error message when you access Calendar or Reports in Microsoft CRM
  5. Verify that you can view Microsoft CRM reports.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB916570, kbtshoot, kbprb, kbmbsmigrate, kberrmsg, kbmbsreports, kbmbscrm40no

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Article Info
Article ID : 916570
Revision : 6
Created on : 12/2/2006
Published on : 12/2/2006
Exists online : False
Views : 379