Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The body of an e-mail message is garbled when the message is viewed in Outlook in an Exchange Server 2003 organization


View products that this article applies to.

Symptoms

When you try to view an e-mail message in Microsoft Outlook in a Microsoft Exchange Server 2003 organization, the body of the e-mail message is garbled. This problem may occur if the following conditions are true:
  • The header field and the body field of the e-mail message are set to different character sets.
  • The different character sets do not belong to the same language group.

↑ Back to the top


Cause

This problem occurs because Exchange Server 2003 sets the PR_INTERNET_CPID property to the UTF-8 character set. The PR_INTERNET_CPID property is a superset for any header field character set and body field character set. When a message uses two different language groups, Outlook tries to display the body of the message in UTF-8. Therefore, the body of the message is garbled.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Hotfix installation information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.After you apply the hotfix, you must configure the following two registry entries:
  • PreserveISO-8859CPIDBody
  • PreserveBodyCPID
This procedure modifies how Exchange Server 2003 behaves when a message is received that has different character sets in the header and in the body.

After you configure the PreserveISO-8859CPIDBody registry entry, you can configure the PreserveBodyCPID registry entry depending on the behavior you want.

When the PreserveBodyCPID registry entry is set to a value of non-zero, the PreserveISO-8859CPIDBody registry entry is ignored. If the PreserveBodyCPID registry entry is set to a value of zero, or if the entry is not present, the behavior of Exchange Server 2003 is controlled by the PreserveISO-8859CPIDBody registry entry.

You can combine the configuration of the two registry entries to achieve a desired result.

To set the body of the message to ISO8859-x

The PreserveISO-8859CPIDBody registry entry sets the PR_INTERNET_CPID property to the ISO8859-x character set when a message contains the UTF-8 character set in the header and the ISO8859-x character set in the body. This registry entry is configured under the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\PARAMETERSSYSTEM\InternetContent
Name: PreserveISO-8859CPIDBody
Value type: DWORD
Value data: 1

To set the body of the message to the codepage

The PreserveBodyCPID registry entry sets the PR_INTERNET_CPID property to the codepage of the body of the message. This registry entry is configured under the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\SERVICES\MSEXCHANGEIS\PARAMETERSSYSTEM\InternetContent
Name: PreserveBodyCPID
Value Type: DWORD
Value data: 1

Prerequisites

You must install Microsoft Exchange Server 2003 Service Pack 2 (SP2) before you apply the hotfix.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply the hotfix. However, the Microsoft Exchange Information Store Service and all dependent services will be restarted.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Exosal.dll6.5.7651.1770,14419-Apr-200607:48x86
Mdbmsg.dll6.5.7651.173,357,18419-Apr-200601:31x86
Store.exe6.5.7651.175,255,16819-Apr-200607:50x86

↑ Back to the top


Workaround

To work around this problem, use one of the following procedures:
  • Remove extended characters from the display name of users in the global address list, if applicable.
  • Open the message in Outlook. Then, change the encoding of the message. To do this, click Encoding on the View menu, and then select the encoding option that you want.
  • Move the message to a .pst folder. Then move the message back to the Inbox.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

This problem occurs when you receive an e-mail message in which the display names in the To and From fields contain extended characters. Messages that contain extended characters in the To and From fields and different character sets in the header and body are typically seen when you receive messages from users who are using Cyrillic, Korean, and Hungarian character sets.
For more information about terminology used in Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about the naming schema for Exchange software updates, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: KB916299, kbbug, kbfix, kbqfe, kbHotfixServer, kbautohotfix

↑ Back to the top

Article Info
Article ID : 916299
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 336