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Error message when you try to go offline in the Microsoft Dynamics CRM laptop client for Outlook: "Failed move data for entity [EntityName] during action saInsert, countRows=[CountNumber]. Contact your system administrator for assistance"


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Symptoms

When you try to go offline in the Microsoft Dynamics CRM laptop client for Microsoft Office Outlook, you may receive the following error message:
Failed move data for entity EntityName during action saInsert, countRows=CountNumber. Contact your system administrator for assistance.
Note In this message, EntityName is a placeholder for the name of an actual entity, and CountNumber is a placeholder for the actual number of rows.

An error message that is similar to the following error message is logged in the event log:
Event Type: Error
Event Source: MSCRMOfflineSync
Event Category: None
Event ID: 6000
Description: An error occurred during Offline Synchronization. Try going offline again, or restart Microsoft Outlook. GetBCPFile() failed during action Insert for entity <Case>, batchRows=0 with exception System.Net.WebException: The remote server returned an error: (401) Unauthorized. ---> System.ComponentModel.Win32Exception: The logon attempt failed at System.Net.NTAuthentication.GetOutgoingBlob(Byte[] incomingBlob, Boolean& handshakeComplete) at System.Net.NTAuthentication.GetOutgoingBlob(String incomingBlob, Boolean& handshakeComplete) at System.Net.NegotiateClient.DoAuthenticate(String challenge, WebRequest webRequest, ICredentials credentials, Boolean preAuthenticate) at System.Net.NegotiateClient.DoAuthenticate(String challenge, WebRequest webRequest, ICredentials credentials, Boolean preAuthenticate) at System.Net.NegotiateClient.Authenticate(String challenge, WebRequest webRequest, ICredentials credentials) at System.Net.AuthenticationManager.Authenticate(String challenge, WebRequest request, ICredentials credentials) at System.Net.AuthenticationState.AttemptAuthenticate(HttpWebRequest httpWebRequest, ICredentials authInfo) --- End of inner exception stack trace --- at System.Net.HttpWebRequest.CheckFinalStatus() at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult) at System.Net.HttpWebRequest.GetResponse() at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.GetBCPFile(String entityName, Action action, Int32 batchSize).
For more information, see Help and Support Center at http://support.microsoft.com.
A warning message that is similar to the following message is logged in the event log:
Event Type: Warning
Event Source: MSCRMOfflineSync
Event Category: None
Event ID: 6001
Description: An unexpected result was returned during Offline Synchronization. #temp<EntityBase> count inserts 54!=27 requested count inserts.
For more information, see Help and Support Center at http://support.microsoft.com.
Note In this message, EntityBase is a placeholder for an actual table name for the entity.

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Cause

This problem occurs because one or more of the following conditions are true:
  • The Microsoft CRM laptop client for Outlook does not have the permissions to access the BCP folder.
  • The version of Microsoft XML (MSXML) on the Microsoft CRM laptop client for Outlook is incorrect.
  • The offline data filters on the Microsoft CRM laptop client for Outlook are incorrect.
  • The Microsoft CRM server installation is corrupted.
  • The user account that runs the application pool on the Microsoft CRM Web site cannot access the offline data folder on the Microsoft CRM server.
  • The Microsoft SQL Server databases are moved to a new server. The Microsoft CRM System DSN ODBC Data Source on the Microsoft CRM server continues to point to the previous server that is running SQL Server.
  • The computer that is running SQL Server and that contains the MSCRM databases is sending more records than is typical to the offline database.
  • The /3GB switch has been added to the Boot.ini file on the Microsoft CRM Server. This problem causes the server to run out of memory when it tries to perform the BCP process.
  • Microsoft Data Access Components (MDAC) 2.8 Service Pack 1 (SP1) is not installed.

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Resolution

To resolve this problem, use one or more of the following methods.

Method 1

Grant permissions for the BCP folder to the Microsoft CRM laptop client for Outlook user. To do this, follow these steps:
  1. Log on to the Microsoft CRM laptop client for Outlook computer, and then locate the BCP folder. Typically, the BCP folder is located on the following path on the client computer:
    C:\Documents and Settings\UserName\Application Data\Microsoft\MSCRM\BCP
    Notes
    • On a Windows Vista-based computer, the BCP folder is located on the following path:
      C:\Users\UserName\AppData\Roaming\Microsoft\MSCRM\BCP
    • In this step, UserName is a placeholder for the actual user name.
  2. Locate and then right-click the folder. Then click Properties.
  3. Click the Security tab.
  4. From the Group or user names list, select the Microsoft CRM laptop client for Outlook user.
  5. In the Permissions for UserName list, make sure that the Allow check box in the Full Control row is selected. Then click OK.

    Note In this step, UserName is a placeholder for the actual user name.

Method 2

Make sure that the version of the Msxml4.dll file is at least 4.20.9828 on the client computer. To do this, follow these steps:
  1. Locate the system32 folder. Typically, this folder is located on the following path:

    C:\WINDOWS\system32\
  2. Locate and right-click the Msxml4.dll file, and then click Properties. Click the Version tab.
  3. Verify whether the value for File version is at least 4.20.9828. If the value is earlier than this version, go to step 4.
  4. If the version of the Msxml4.dll file is earlier than 4.20.9828, the file must be updated. For more information about how to obtain an updated file, visit the following Microsoft Web site:Notes
    • You can also obtain the Msxml4.dll file from the client installation CD. Typically, the Msxml4sp2-kb887606-x86-enu.exe file is located on the following path:

      \Client\MSXML\KB887606\
    • This fix does not require that you restart the computer.

Method 3

Remove all the offline data filters, and then add and synchronize these filters one by one on the client computer. To remove the offline data filters, follow these steps:
  1. In the Microsoft CRM laptop client for Outlook, click Local Data on the CRM menu.
  2. In the Local Data dialog box, highlight all filters, click Deactivate, and then click OK.
To add and synchronize the filters, follow these steps:
  1. On the CRM menu, click Local Data.
  2. Click the Inactive Data Groups tab.
  3. Select one of the filters. Then click Activate.
  4. Click OK.
  5. Click Go Offline to start the synchronization process. Then click Go Online to complete the synchronization process.
  6. Repeat steps 3 through 5 for each deactivated filter.
  7. If you can identify a specific filter that is causing the issue, make sure that this filter does not use the "Parent Downloaded = True" instruction. We do not recommend using this instrucion.

Method 4

Run the repair process on the Microsoft CRM server. To do this, follow these steps:
  1. Log on to the Microsoft CRM server. Click Start, click Control Panel, and then click Add or Remove Programs.
  2. Click Microsoft CRM Server. Then click Change/Remove.
  3. Click the Repair option. Then click Next to start the Microsoft CRM 3.0 Server Setup wizard.

Method 5

Make sure that the user account that runs the application pool on the Microsoft CRM Web site can access the OfflineData folder. This folder stores the BCP (Bulk Copy Process) data files that the client obtains from the server that is running SQL Server. To make sure that the OfflineData folder can be accessed, follow these steps:
  1. Determine which account is running the application pool. To do this, follow these steps:
    1. Log on to the Microsoft CRM server.
    2. Click Start, click Administrative Tools, and then click Internet Information Services (IIS) Manager.
    3. Expand the local computer name, expand Application Pools, right-click CRMAppPool, and then click Properties.
    4. Click the Identity tab.
    5. Verify permissions according to the following guidelines:

      If the Predefined option is selected, both the NetworkService and LocalSystem accounts are represented by the DomainName\ComputerName$ account. Therefore, when you must verify permissions for the NetworkService account or for the LocalSystem account, you must also verify permissions for the DomainName\ComputerName$ account.

      If the Configurable option is selected, you must verify permissions for the specified user account.

      Note If the Predefined option is selected, use the DomainName\ComputerName$ account as the user in step 5. If the Configurable option is selected, use the specified user account as the user in step 5.
  2. On the Microsoft CRM server, locate the following folder:

    Drive:\Program Files\Microsoft CRM\Server\OfflineData\

    Note In this step, Drive is a placeholder for the actual drive on which you installed Microsoft CRM.
  3. Right-click the folder. Then click Properties.
  4. Click the Security tab.
  5. From the Group or user names list, select the user who you identified in step 1.
  6. In the Permissions for UserName list, make sure that the Allow check box in the Full Control row is selected. Then click OK.

    Note In this step, UserName is a placeholder for the actual user name.

Method 6

Note Method 6 is only valid for Microsoft Dynamics CRM 3.0. This method is not valid for Microsoft Dynamics CRM 4.0.

Modify the Microsoft CRM System DSN ODBC Data Source on the Microsoft CRM server to point to the new server that is running SQL Server. To do this, follow these steps:
  1. Click Start, point to Administrative Tools, and then click Data Sources (ODBC).
  2. In the ODBC Data Source Administrator dialog box, click the System DSN tab, click the Microsoft CRM in the System Data Sources list, and then click Configure.
  3. In the first Microsoft SQL Server DSN Configuration window, locate the Server list that contains the names of computers that are running SQL Server. Click the server that you want to connect to.
  4. Click Next three times to configure the data source.
  5. Click Finish.
  6. In the ODBC Microsoft SQL Server Setup window, click Test Data Source to validate the connection to the server.
  7. Click OK two times to complete the configuration.
  8. Click OK to close the ODBC Data Source Administrator dialog box.

Method 7

  1. Exit Microsoft Dynamics CRM 3.0.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:
    HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
  4. Right-click the OfflineRowsBatchSize DWORD value, and then click Modify.
  5. In the Value data box, type a value that is smaller than the current value, such as 10 or 1. Then click OK.

    Note By default, the OfflineRowsBatchSize DWORD value is set to 100000.
  6. Exit Registry Editor.

Method 8

Remove the /3GB switch from the Boot.ini file on the Microsoft CRM server. For the change to take effect, you must restart the computer after you remove the switch.

Method 9

Install MDAC 2.8 Service Pack 1. To install MDAC 2.8 SP1, visit the following Microsoft Web site:

Method 10

If recent updates to the Windows operating system were applied to the Microsoft Dynamics CRM server or to the server that is running SQL Server, restart the affected server.

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More information

If you still experience the problem that is described in the "Symptoms" section, click the following article number to view the article in the Microsoft Knowledge Base:
918108 Error message when you try to go offline on a laptop client computer that is running Microsoft Dynamics CRM 3.0: "Failed move data for entity"

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References

For more information about how to move Microsoft Dynamics CRM 3.0 SQL databases from one server to another server, click the following article number to view the article in the Microsoft Knowledge Base:
917948 How to move Microsoft Dynamics CRM 3.0 SQL databases from one server to a different server that is in the same domain

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Keywords: KB916165, kbtshoot, kbprb, kbmbsmigrate, kberrmsg, kbcrmv3c, kbmbscrm40no

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Article Info
Article ID : 916165
Revision : 8
Created on : 1/15/2009
Published on : 1/15/2009
Exists online : False
Views : 378