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You experience slower performance than typical in Microsoft Dynamics CRM 3.0 when the MSCRM Stored Procedure Priming job is running


View products that this article applies to.

Symptoms

In Microsoft Dynamics CRM 3.0, you experience slower performance than typical when the MSCRM Stored Procedure Priming job is running. You notice one or more of the following symptoms:
  • Database records are slower than typical.
  • CPU usage is more than typical.
  • There are unexpected increases in the following performance counters:
    • SQL Server: SQL Statistics: Batch Requests/sec
    • SQL Server: SQL Statistics: SQL Compilations/sec
    • SQL Server: SQL Statistics: SQL Recompilations/sec
    • Physical Disk: Avg Disk Queue Length

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Cause

This problem occurs because the MSCRM Stored Procedure Priming job exists to keep the Microsoft Dynamics CRM cascading stored procedures in the Microsoft SQL Server procedure cache. By default, the MSCRM Stored Procedure Priming job is scheduled to run every 10 minutes. The frequency of running the job can cause the CPU usage to spike on the SQL Server that contains the Microsoft Dynamics CRM databases.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile sizeDateTime
Invoice status detail.rdl63,43612-Sep-200623:19
Invoice status.rdl31,78812-Sep-200623:19
Sales pipeline.rdl108,50712-Sep-200623:19
Service activity volume detail.rdl100,12412-Sep-200623:19
Service activity volume.rdl65,20012-Sep-200623:19

Installation information

Install this hotfix on computers that are running Microsoft Dynamics CRM 3.0 server.

Prerequisites

There are no prerequisites to apply this hotfix.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

Removal information

To remove this hotfix from a computer that is running Microsoft Dynamics CRM 3.0 server, use Add or Remove Programs in Control Panel. System administrators can use the Spunist.exe utility to remove this hotfix from a computer that is running Microsoft Dynamics CRM 3.0 server.

The Spuninst.exe tool is located in the %Windir%\$NTUninstallKB915722$\Spuninst folder.

More information about the hotfix

This hotfix resolves this problem only when you are in online mode in the Microsoft Dynamics CRM client for Outlook. This hotfix does not resolve the problem if you are in offline mode in the Microsoft Dynamics CRM laptop client for Outlook.

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Workaround

To work around this problem, change the schedule for the MSCRM Stored Procedure Priming job. To do this, follow these steps depending on the version of SQL Server that you are using.

SQL Server 2005

  1. Click Start, point to All Programs, point to Microsoft SQL Server 2005, and then click SQL Server Management Studio.
  2. Connect to the SQL Server that contains the Microsoft Dynamics CRM databases.
  3. Click SQL Server Agent.
  4. Click Jobs, and then double-click MSCRM Stored Procedure Priming Job.
  5. Click the Schedules tab, and then double-click the Stored Procedure Priming schedule.
  6. In the Daily frequency box, select the time interval that you want. For example, select 4 hours.
  7. Click OK to close the dialog boxes.

SQL Server 2000

  1. Click Start, point to All Programs, point to Microsoft SQL Server, and then click Enterprise Manager.
  2. Expand Microsoft SQL Servers, expand SQL Server Group, and then expand the local server.
  3. Expand Management, and then expand SQL Server Agent.
  4. Click Jobs, and then double-click MSCRM Stored Procedure Priming Job.
  5. Click the Schedules tab, and then double-click the listed schedule. The schedule should be set to Recurring.
  6. Click Change.
  7. In the Daily frequency box, select the time interval that you want. For example, select 4 hours.
  8. Click OK to close the dialog boxes.

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More information

For information about performance tuning for CRM 3.0, see the following white paper: For more information about software update terminology, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
887283 Microsoft Business Solutions CRM software hotfix and update package naming standards

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Keywords: KB915722, kbmbsmigrate, kbqfe, kbhotfixserver, kbmbsadministration, kbautohotfix

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Article Info
Article ID : 915722
Revision : 5
Created on : 5/10/2007
Published on : 5/10/2007
Exists online : False
Views : 419