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Blocks of time may be off by one hour when you view free/busy information for a user of a third-party messaging system in Exchange Server 2003


View products that this article applies to.

Symptoms

You view the free/busy information for a user of a third-party messaging system. When you do this, the blocks of time may be off by one hour in your calendar in Microsoft Exchange Server 2003.

For example, when a user of a third-party messaging system is busy from 9:00 A.M. to 10:00 A.M., this block of time may be displayed as 8:00 A.M. to 9:00 A.M.

This problem also occurs when a user of a third-party messaging system views your free/busy information.

Note Examples of third-party messaging systems include Lotus Notes and Novell GroupWise.

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Cause

This behavior may occur if the following conditions are true:
  • The free/busy time that you view is created by Microsoft Exchange Server 2003 Calendar Connector.
  • The transition date to standard time (STD) and daylight saving time (DST) changed since the internal tables for time zones were hard-coded in Calendar Connector.
Calendar Connector uses the hard-coded internal tables for time zones to compute the correct time for free blocks or busy blocks. Calendar Connector does this when it makes free/busy information available to participants who are in different time zones. Calendar Connector continues to calculate the switch between STD and DST based on these tables. It does this even if the actual date or time of the transition between STD and DST has changed in a time zone. Therefore, Calendar Connector may pass out-of-date information to other programs. That information is then displayed to the user.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft Exchange Server 2003 Service Pack 2 installed to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix. The Calendar Connector service is stopped and then restarted when the hotfix is applied.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Rtdsmcal.dll6.5.7651.2432,25618-May-200600:55x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The transitions between STD and DST are changed in the following time zones as follows:
  • The Western European Standard Time transition is changed from the last Sunday in September to the last Sunday in October.
  • The Central European Summer Time transition is changed from midnight on the last Sunday of March to 2 A.M. on the last Sunday of March.
  • The Central European Standard Time transition is changed from the last Sunday in September to the last Sunday in October.
  • The Eastern European Summer Time transition is changed from midnight on the last Sunday of March to 3 A.M. on the last Sunday of March.
  • The Eastern European Standard Time transition is changed from the last Sunday in September at midnight to the last Sunday in October at 4 A.M.
  • The Eastern Australian Standard Time transition is changed from the first Sunday of March to last Sunday of March. Additionally, new time zones are added for the 2006 Commonwealth Games in Australia.
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
817903 New naming schema for Exchange Server software update packages

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Keywords: KB915494, kbbug, kbfix, kbqfe, kbHotfixServer, kbautohotfix, kbarchive, kbnosurvey

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Article Info
Article ID : 915494
Revision : 5
Created on : 1/15/2015
Published on : 1/15/2015
Exists online : False
Views : 264