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A PROPPATCH request to update the security descriptor of the public folder appears to succeed, but the update is unsuccessful in Exchange Server 2003


View products that this article applies to.

Symptoms

Microsoft Exchange Server 2003 has a 32,768-byte (32KB) discretionary access control list (DACL) entry limit for each public folder.

If you exceed this limit when you try to modify the public folder permissions by using a MAPI program such as Exchange System Manager, you receive the following error message as expected:
Error 80040305
However, if you exceed this limit when you try to modify the public folder permissions programmatically through WebDAV by using the PROPPATCH method, you experience the following symptoms:
  • The PROPPATCH request to update the security descriptor of the public folder appears to succeed. When you view the HTTP response to the PROPPATCH request, you notice that HTTP returns a "200 OK" response.
  • The public folder permissions are not successfully updated.
You expect to receive an error response to a PROPPATCH request to update the security descriptor of a public folder if that update exceeds the 32KB DACL limit.

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Cause

This problem occurs because Exchange does not correctly handle an error situation that occurs when Exchange sets the ptagNTSD data. In this situation, Exchange incorrectly overwrites the error code that Exchange receives.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the Microsoft Exchange Information Store service and all its dependent services are automatically stopped and then restarted when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Mdbmsg.dll6.5.7651.103,357,18415-Mar-200603:16x86
Store.exe6.5.7651.105,250,04815-Mar-200618:27x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
817903 New naming schema for Exchange Server software update packages

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Keywords: KB915325, kbbug, kbfix, kbqfe, kbhotfixserver, kbautohotfix, kbarchive, kbnosurvey

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Article Info
Article ID : 915325
Revision : 4
Created on : 1/15/2015
Published on : 1/15/2015
Exists online : False
Views : 246