Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you click certain links in the Project center page in Business Portal for Microsoft Dynamics SL


View products that this article applies to.

Symptoms

Consider the following scenarios in Business Portal for Microsoft Dynamics SL and for Microsoft Business Solutions - Solomon:
  • When you click the Time link under the Project center page in Business Portal, you receive the following error message:
    Error retrieving Project Employee information on Time entry
  • When you click the Document Approvals link under the Project center page in Business Portal, you receive the following error message:
    Error in /Application the resource cannot be found in Time and Expense approval
  • Under the Project center page in Business Portal, you receive the following error message in the Communicator Web Part:
    Error retrieving Project Employee information: ERROR
  • When you click the Edit or Reject link under the Executive Line Item Approvals page for an expense item, you receive the following error message:
    ASP Error encountered in: GRFUNCTION.ASP / IsModuleUnlocked Error #424 Object required

↑ Back to the top


Cause

This problem occurs because a valid back-office ID is not assigned to a role.

Note In the Manage Business Portal Users pane, the Back Office ID box for a role that is assigned to the Business Portal user contains the default Unspecified value.

↑ Back to the top


Resolution

To resolve this problem, assign a valid back-office ID to the role that does not have a valid back-office ID. To do this, follow these steps:
  1. Sign in to Business Portal as the administrator.
  2. Click Site Settings, and then click Manage Business Portal Users.
  3. In the User List Web part, select the appropriate user ID.
  4. In the User Properties Web part, click the Roles tab.
  5. Assign a valid back-office ID to the role that does not have a valid back-office ID.


The issue that is described in the Symptoms section does not apply to Microsoft Dynamics SL 7.0.

↑ Back to the top


Keywords: kbmbssl7no, kbfreshness2007, kbsolomonbp, kbmbspsatandeforprojects, kbmbspsaprojectcontrollerpremier, kbmbsbusinessportalsdk, kbmbspartner, kbmbsmigrate, kbprb, kb

↑ Back to the top

Article Info
Article ID : 915315
Revision : 2
Created on : 2/2/2017
Published on : 2/3/2017
Exists online : False
Views : 288