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The LSASS.exe process reaches a very high handle count after you configure SSL on the Exchange virtual server when you run Exchange Server 2003 on a server cluster


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You run Microsoft Exchange Server 2003 on a server cluster.
  • You configure Secure Sockets Layer (SSL) on the Exchange virtual server for Microsoft Outlook Web Access.
In this scenario, you notice that the LSASS.exe process reaches a very high handle count after many days. Eventually, the cluster node runs out of kernel resources. And, you must restart the cluster node.

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Cause

This problem occurs because the Exchange Exres.dll component does not release system resources after it is finished with these resources if SSL is configured on the virtual server.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, you must have Microsoft Exchange Server 2003 Service Pack 2 (SP2) installed to apply this hotfix.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the Microsoft Exchange Information Store service and all its dependent services are automatically stopped and then restarted when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File nameFile versionFile sizeDateTimePlatform
Exres.dll6.5.7651.10134,65615-Mar-200602:50x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about a similar problem that you may experience in a clustered Exchange Server 2003 environment, click the following article number to view the article in the Microsoft Knowledge Base:
889406 The Exchange services stop on the active node if you configure SSL for Outlook Web Access on the virtual server in an Exchange Server 2003 clustered environment

For more information about a follow-up issue that may occur when you install the fix that is mentioned in this article, click the following article number to view the article in the Microsoft Knowledge Base:
949412 Event ID 1014 and Event 1005 are logged in the Application log after you use an SSL certificate for Exchange virtual server on an Exchange Server 2003-based cluster

For more information about the terminology that Microsoft uses for software that is corrected after it is released, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages

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Keywords: KB915197, kbbug, kbfix, kbqfe, kbHotfixServer, kbautohotfix, kbarchive, kbnosurvey

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Article Info
Article ID : 915197
Revision : 5
Created on : 1/16/2015
Published on : 1/16/2015
Exists online : False
Views : 243