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An Outlook 2003 client cannot connect to the server after a mailbox is moved from Exchange 2000 Server to Exchange Server 2003


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Symptoms

A mailbox is moved from a server that is running Microsoft Exchange 2000 Server to a server that is running Microsoft Exchange Server 2003. When this occurs, a Microsoft Office Outlook 2003 client that is configured to use Cached Exchange Mode cannot connect to the Exchange 2003 server. This issue could be permanent, or could affect the user for only several hours.

If your Outlook 2003 profile is configured to use Cached Exchange Mode, you may experience one or both of the following symptoms when you log on to the Exchange server by using Outlook 2003:
  • Before you are connected to the Exchange server for the first time after your mailbox is moved from the Exchange 2000 server to the Exchange 2003 server, a delay occurs. Outlook 2003 tries to connect to the Exchange 2000 server on which your mailbox was previously stored. After a delay, Outlook 2003 connects to the Exchange 2003 server on which your mailbox is currently stored.
  • Outlook cannot retrieve the name for the new server. Instead, Outlook tries to connect to the Exchange 2000 server on which your mailbox was previously stored. However, this operation fails. Additionally, Outlook goes into a disconnected state.

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Cause

The Outlook 2003 client tries to connect with the profile that was created to connect to the old Exchange 2000 server. This profile was not updated with the information that is required to connect to the new Exchange 2003 server. The Exchange 2000 server responds to the client that the Exchange 2000 server is the wrong server. The Exchange 2000 server then returns the distinguished name (DN) of the new Exchange 2003 server.

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More information

In Outlook 2002, the client used the DN to extract the short name of the Exchange server. However, Outlook 2003 requires the client to use the Fully Qualified Domain Name (FQDN) of the server to connect. By using the DN that is returned for the new server, Outlook 2003 will try to retrieve the FQDN by using the Referral (RFR) service on an Exchange 2003 server.

Note Exchange Server 2003 is the first version of Exchange Server to provide FQDN name translation.

In this case, the client profile version is still Exchange 2000, because the client has not successfully logged on to the Exchange 2003 mailbox. Therefore, the client cannot make an RFR request to translate the DN of the new server to an FQDN.

Outlook 2003 will try to retrieve the network address of the Exchange server (PR_EMS_AB_NETWORK_NETWORK_ADDRESS). To do this, Outlook 2003 first performs a query against the offline address book. Outlook 2003 then tries to use the information from version 3 of the offline address book to retrieve the Exchange server network address. The cached version 3 of the offline address book contains information for the old Exchange server. Because the Outlook 2003 client always tries to use the FQDN first, this process causes the connection problem to occur.

Note This issue does not occur with clients that use version 2 of the offline address book.

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Resolution

To resolve this issue, use one of the following methods:
  • Install the hotfix for this issue. For more information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base:
    839647 Description of the Outlook 2003 post-Service Pack 1 hotfix package
  • Install Microsoft Office Outlook 2003 Service Pack 2.

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Keywords: KB914855, kbprb

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Article Info
Article ID : 914855
Revision : 6
Created on : 4/28/2006
Published on : 4/28/2006
Exists online : False
Views : 455