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Error message when you try to view the activities for an account in Microsoft Dynamics CRM 3.0: "A SQL Server error occurred"


View products that this article applies to.

Symptoms

You cannot view the activities for an account in Microsoft Dynamics CRM 3.0. Additionally, you receive the following error message:
SQL Server Error

A SQL Server error occurred. For more information, contact your system administrator.
If you have the DevErrors parameter enabled, you also receive the following error message:
Microsoft CRM Unhandled Error Details:
Server Error in '/' Application.
--------------------------------------------------------------------------------

Server was unable to process request.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Web.Services.Protocols.SoapException: Server was unable to process request.

Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[SoapException: Server was unable to process request.]
System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message,
WebResponse response, Stream responseStream, Boolean asyncCall) +1495
System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) +217
Microsoft.Crm.Platform.Proxy.ActivityPointerWebService.RollupByObject(Guid rollupById, String rollupByName, RollupType rollupType, QueryBase queryExpression) +148
Microsoft.Crm.Application.SMWrappers.ActivityPointer.RollupByObject(Guid rollupById, String rollupByName, RollupType rollupType, QueryExpression activityQueryExpression) +44
Microsoft.Crm.Application.Platform.ActivityPointer.RollupByObject(CObjectName gridObjectName, RollupType rollupType, QueryExpression activityQueryExpression) +119
Microsoft.Crm.ApplicationQuery.ExecuteActivityAPI(String api) +232
Microsoft.Crm.ApplicationQuery.ExecuteAPI(String queryApi) +2726
Microsoft.Crm.ApplicationQuery.GetViewData() +91 Microsoft.Crm.Application.Controls.ActivitiesGridDataProvider.GetDataXml(QueryBuilder qb) +189 Microsoft.Crm.Application.Controls.AppGridDataProvider.Execute() +156 Microsoft.Crm.Application.Controls.ActivitiesGridDataProvider.Execute() +4 Microsoft.Crm.Application.Controls.AppGridUIProvider.Render(HtmlTextWriter output) +229 Microsoft.Crm.Application.Components.UI.DataGrid.RenderData(HtmlTextWriter output) +525 Microsoft.Crm.Application.Components.UI.DataGrid.RenderInnerHtml(HtmlTextWriter output) +471 Microsoft.Crm.Application.Components.UI.DataGrid.Render(HtmlTextWriter output) +125 Microsoft.Crm.Application.Controls.AppGrid.Render(HtmlTextWriter writer) +128 System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +243 Microsoft.Crm.Application.Controls.AppAreaPage.Render(HtmlTextWriter output) +427 System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +243
System.Web.UI.Page.ProcessRequestMain() +1926

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Cause

This problem may occur if the following conditions are true:
  • A lead is converted to an opportunity. Additionally, the lead is associated with an existing account.
  • The lead is re-activated.
  • The lead is again converted to an opportunity. Additionally, the lead is associated with the same existing account with which it was associated before.

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Resolution

Microsoft Dynamics CRM 3.0

Update rollup information

This problem is fixed in Microsoft Dynamics CRM 3.0 Update Rollup 1. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
922815 Update Rollup 1 for Microsoft Dynamics CRM 3.0 is available

Microsoft Dynamics CRM 3.0, Japanese version or Chinese version

Update rollup information

This problem is fixed in Update Rollup 2 for the Chinese Simplified version of Microsoft Dynamics CRM 3.0 and for the Japanese version of Microsoft Dynamics CRM 3.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
944372 Update Rollup 2 for the Chinese Simplified version of Microsoft Dynamics CRM 3.0 and for the Japanese version of Microsoft Dynamics CRM 3.0 is available

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More information

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
887283 Microsoft Business Solutions CRM software hotfix and update package naming standards

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Keywords: KB914644, kbmbsmigrate, kbbug, kberrmsg, kbautohotfix, kbhotfixserver

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Article Info
Article ID : 914644
Revision : 9
Created on : 5/15/2008
Published on : 5/15/2008
Exists online : False
Views : 403