Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Terminal Server object and the object of the Terminal Server session for a Windows Server 2003 Terminal Server are unavailable when you use Performance Monitor on a remote computer


View products that this article applies to.

Symptoms

When you use Performance Monitor to remotely monitor the performance of a Microsoft Windows Server 2003 Terminal Server, the Terminal Server object and the object of the Terminal Server session are unavailable. This issue occurs even when the remote user is a member of the Performance Monitor Users group on the Windows Server 2003 Terminal Server.

↑ Back to the top


Cause

This issue occurs if the Performance Monitor Users group does not have permissions to the Application log in Windows Server 2003.

↑ Back to the top


Resolution

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

↑ Back to the top


Workaround

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To work around this issue, give Read permissions and Write permissions to the Performance Monitor Users group for the Application log in Windows Server 2003. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate, and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application
  3. In the right pane, right-click CustomSD, and then click Modify.
  4. In the Edit String dialog box, append the following string to the value that appears in the Value data box:
    (A;;0x3;;;MU)
  5. On the File menu, click Exit.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

For more information about event log security, click the following article number to view the article in the Microsoft Knowledge Base:
323076 How to set event log security locally or by using Group Policy in Windows Server 2003
For more information about security descriptors, visit the following Microsoft Web sites:

↑ Back to the top


Keywords: kbwinserv2003sp2fix, kbwinservperf, kbtermserv, kbtshoot, kbprb, KB914539

↑ Back to the top

Article Info
Article ID : 914539
Revision : 8
Created on : 5/8/2007
Published on : 5/8/2007
Exists online : False
Views : 277