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Web applications that use chunked encoding stop responding when you access them from a Windows Server 2003-based or from a Windows XP-based computer


View products that this article applies to.

Symptoms

You access Web applications or Web sites from a Web server that uses chunked transfer encoding on a Microsoft Windows Server 2003-based or on a Microsoft Windows XP-based computer. Then, the browser or the Web applications stop responding.

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Cause

This problem occurs when the Wininet.dll file receives an incomplete chunk of data during the initial Winsock data receive operation. When this behavior occurs, the second Winsock data receive operation reads only a chunk token. For example, the second Winsock data receive operation may only read carriage-return line-feed (CRLF) from the socket. Then, the Wininet.dll file makes continuous calls to the Winsock Select function for 30 seconds. The file is waiting to receive more data. However, if no data arrives, the browser or the Web application stops responding.

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Resolution

Windows Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformService pack requirementService branch
Wininet.dll6.0.3790.495628,73602-Mar-200619:15x86NoneRTMQFE
Wininet.dll6.0.3790.2651665,08802-Mar-200619:24x86SP1SP1QFE
After you install the hotfix, you must modify the registry to enable the hotfix. To do this, follow these steps: Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start, click Run, type Regedit, and then click OK.
  2. To enable this hotfix per user, locate and then click the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
    To enable this hotfix per computer, locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Click the registry subkey that you located in step 2.
  4. On the Edit menu, point to New, and then click Key.
  5. Type FEATURE_CHUNK_TIMEOUT_KB914453, and then press ENTER.
  6. Click the registry key you created in step 5.
  7. On the Edit menu, point to New, and then click Key.
  8. Type Settings, and then press ENTER.
  9. Click FEATURE_CHUNK_TIMEOUT_KB914453.
  10. On the Edit menu, point to New, and then click DWORD Value.
  11. Type Iexplore.exe, and then press ENTER.
  12. On the Edit menu, click Modify.
  13. In the Value data box, type 1, and then click OK.

    Note The valid values for the subkey are 0 and 1. A value of 1 enables the hotfix, and a value of 0 disables the hotfix.
  14. Click FEATURE_CHUNK_TIMEOUT_KB914453.
  15. Click Settings.
  16. On the Edit menu, point to New, and then click DWORD Value.
  17. Type ChunkSelectTimeout, and then press ENTER.
  18. On the Edit menu, click Modify.
  19. In the Value data box, type FFFFFFFF, and then click OK.

    Note The valid values for the subkey are based on a delay. A value of FFFFFFFF enables the hotfix, and any other value indicates the time-out value.
  20. Exit Registry Editor.
Note If you update the
HKEY_LOCAL_MACHINE
registry subtree, you must restart the computer. Then, you must log off and log on the computer to see the behavior changes.

Windows XP

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Wininet.dll6.0.2900.2859663,55201-Mar-200621:16x86
After you install the hotfix, you must modify the registry to enable the hotfix. To do this, follow these steps: Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start, click Run, type Regedit, and then click OK.
  2. To enable this hotfix per user, locate and then click the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
    To enable this hotfix per computer, locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Click the registry key you located in step 2.
  4. On the Edit menu, point to New, and then click Key.
  5. Type FEATURE_CHUNK_TIMEOUT_KB914453, and then press ENTER.
  6. Click the registry key you created in step 5.
  7. On the Edit menu, point to New, and then click Key.
  8. Type Settings, and then press ENTER.
  9. Click FEATURE_CHUNK_TIMEOUT_KB914453.
  10. On the Edit menu, point to New, and then click DWORD Value.
  11. Type Iexplore.exe, and then press ENTER.
  12. On the Edit menu, click Modify.
  13. In the Value data box, type 1, and then click OK.

    Note The valid values for the subkey are 0 and 1. A value of 1 enables the hotfix, and a value of 0 disables the hotfix.
  14. Click FEATURE_CHUNK_TIMEOUT_KB914453.
  15. Click Settings.
  16. On the Edit menu, point to New, and then click DWORD Value.
  17. Type ChunkSelectTimeout, and then press ENTER.
  18. On the Edit menu, click Modify.
  19. In the Value data box, type FFFFFFFF, and then click OK.

    Note The valid values for the subkey are based on a delay. A value of FFFFFFFF enables the hotfix, and any other value indicates the time-out value.
  20. Exit Registry Editor.
Note If you update the
HKEY_LOCAL_MACHINE
registry subtree, you must restart the computer. Then, you must log off and log on the computer to see the behavior changes.

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Workaround

To work around this problem, use one of the following options:
  • Disable the chunked encoding from the Web server. For more information about whether the Web server lets you disable chunked encoding, and for information about how to disable chunked encoding, see the Web server product documentation.
  • Disable the HTTP 1.1 settings in Microsoft Internet Explorer. To do this, follow these steps:
    1. Close all the currently active Internet Explorer windows.
    2. Start Internet Explorer.
    3. On the Tools menu, click Internet Options.
    4. In the Internet Options dialog box, click the Advanced tab.
    5. Under HTTP 1.1 settings in the Settings list, click to clear the Use HTTP 1.1 check box.
    6. Under HTTP 1.1 settings, click to clear the Use HTTP 1.1 through proxy connections check box, and then click OK.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinserv2003presp2fix, kbwinxppresp3fix, kbbug, kbfix, kbHotfixServer, kbqfe, kbwinserv2003sp2fix, KB914453

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Article Info
Article ID : 914453
Revision : 4
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 267